Cannot mix incompatible libraries

B

BSDAppentic3

Guest


#1
Hello whoever is reading this.
I have been stuck in the same...you know what I mean.
I have a problem with VirtualBox.
NO matter of the procedure that I make for install this program, will be pkg, using ports, whatever. When it finish its installation, and I try to run this program, ALWAYS I get the same **** error.
Code:
Qt WARNING: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Qt FATAL: Cannot mix incompatible Qt library (version 0x50701) with this library (version 0x50904)
Abort trap
Now I'm trying with
Code:
 make
inside of the ports. I've tried with
Code:
 pkg
but it was useless. I have hope in make, for some strange reason. Maybe should I download src.txz, then make
Code:
 portsmaster
?
 

juan9182

Active Member

Thanks: 19
Messages: 166

#3
the same happen to me but with qbittorrent

Cannot mix incompatible Qt library (version 0x50701) with this library (version 0x50904)

edit..this happend when i install a set of packages(gtk,cursor and themes pkg with -y switch) me bad..
 
OP
OP
B

BSDAppentic3

Guest


#5
i found the solution..update all

pkg update
pkg upgrade
Ah ah, no. That didn't work for me.
Look at this:
Code:
Proceed with this action? [y/N]: y
[1/240] Fetching zenity-3.18.0.txz: 100%    3 MiB  93.6kB/s    00:36   
pkg: cached package zenity-3.18.0: size mismatch, fetching from remote
[2/240] Fetching zenity-3.18.0.txz: 100%    3 MiB 102.2kB/s    00:33   
pkg: cached package zenity-3.18.0: size mismatch, cannot continue
Edit: removed zenity, and following this: https://forums.freebsd.org/threads/pkg-1-3-0-size-mismatch-cannot-continue.47444/
Now I can make an upgrade.
 
Top