Cannot access any settings in gnome

neilms

Active Member

Reaction score: 11
Messages: 205

Hello everyone
I’m running freebsd 12. By default only the console starts. If I do startx the gnome desktop does start. Note I do not use gdm because I do not always want windows to start.

The main problem at the moment is that the screen resolution in gnome is not what I want. It is too small. If I go to settings they are all locked as if I don’t have permission to change them. So I logged on as root and then ran startx. In the settings for resolution there is only one displayed setting which cannot be changed. In Linux there would be a list of several different resolutions to try which a dialog that asks if you want to keep it or revert to previous resolution. How can I make my resolution fit my preference as an ordinary user?

I have another problem but that belongs in another forum as it is about the console.
 

obsigna

Daemon

Reaction score: 909
Messages: 1,321

I am also fighting with GNOME3 and its settings, and I don’t know whether the following applies to your setup.
I found out that I need gdm, because every other method of starting GNOME3 leaves the keychain closed and it even does not save passwords of the browser beyond of the next restart.

My suggestion is, to try gdm again. It is quite straightforward to use it on-demand, namely don’t enable it in /etc/rc.conf. And when you need it, then issue as superuser service gdm onestart. OK, this command got 3½ times more letters than startx, but you could alias it.

Anyway, starting GNOME3 via gdm, I am able to adjust the video mode in Settings > Devices. When starting via startx, I am not. I guess, you knew this already.
 
OP
neilms

neilms

Active Member

Reaction score: 11
Messages: 205

I am also fighting with GNOME3 and its settings, and I don’t know whether the following applies to your setup.
I found out that I need gdm, because every other method of starting GNOME3 leaves the keychain closed and it even does not save passwords of the browser beyond of the next restart.

My suggestion is, to try gdm again. It is quite straightforward to use it on-demand, namely don’t enable it in /etc/rc.conf. And when you need it, then issue as superuser service gdm onestart. OK, this command got 3½ times more letters than startx, but you could alias it.

Anyway, starting GNOME3 via gdm, I am able to adjust the video mode in Settings > Devices. When starting via startx, I am not. I guess, you knew this already.
I didn’t know!
I will try it again with gdm. All I want to do is set my screen to 1024*768 resolution.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,152
Messages: 39,767

This might be due to ConsoleKit (or whatever it's called these days). With GDM a ConsoleKit session is automatically started. If I recall correctly gnome-session would start it too. But this may have changed with more recent versions. It's the lack of a CK session that's often the reason why you can't change settings (or do other things).

When you start with startx, open a terminal and run ck-list-sessions. It should provide some information like this:
Code:
dice@williscorto:~ % ck-list-sessions
Session1:
        unix-user = '1001'
        realname = 'SirDice'
        seat = 'Seat2'
        session-type = 'x11'
        session-class = 'user'
        session-state = 'online'
        active = FALSE
        x11-display = 'unix:0.0'
        x11-display-device = '/dev/tty9'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2019-11-06T21:25:28.750796Z'
        login-session-id = ''
        XDG_RUNTIME_DIR = '/var/run/user/1001'

If that's missing try this in ~/.xinitrc:
Code:
exec dbus-launch --exit-with-session ck-launch-session gnome-session

Also check and verify that D-Bus is running.
Code:
sysrc dbus_enable="YES"
service dbus start
 
OP
neilms

neilms

Active Member

Reaction score: 11
Messages: 205

This might be due to ConsoleKit (or whatever it's called these days). With GDM a ConsoleKit session is automatically started. If I recall correctly gnome-session would start it too. But this may have changed with more recent versions. It's the lack of a CK session that's often the reason why you can't change settings (or do other things).

When you start with startx, open a terminal and run ck-list-sessions. It should provide some information like this:
Code:
dice@williscorto:~ % ck-list-sessions
Session1:
        unix-user = '1001'
        realname = 'SirDice'
        seat = 'Seat2'
        session-type = 'x11'
        session-class = 'user'
        session-state = 'online'
        active = FALSE
        x11-display = 'unix:0.0'
        x11-display-device = '/dev/tty9'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2019-11-06T21:25:28.750796Z'
        login-session-id = ''
        XDG_RUNTIME_DIR = '/var/run/user/1001'

If that's missing try this in ~/.xinitrc:
Code:
exec dbus-launch --exit-with-session ck-launch-session gnome-session

Also check and verify that D-Bus is running.
Code:
sysrc dbus_enable="YES"
service dbus start
D-bus and console kit seem ok as I get output to what SirDice gave.
I tried with KDE but get the same problem. There is only one default resolution . I attempted to charge it with xrandr -s 1024 x 768 at command line but that had no effect either.
 
Top