can not install nspluginwrapper: linux-glib2-2.6.6_1 conflicts with linux_base-f8-8_9

edhunter

Member

Reaction score: 10
Messages: 71

Hello :)
I am trying to install flash9 on freebsd using this recent guide http://crnl.org/blog/2008/11/01/flash-9-for-freebsd-71
the steps for installing ports are ...
cd /usr/ports/emulators/linux_base-f8 && make install clean
cd /usr/ports/www/linux-flashplugin9 && make install clean
cd /usr/ports/www/nspluginwrapper && make install clean

I am on the last step and I am getting error
===> linux-glib2-2.6.6_1 conflicts with installed package(s):
linux_base-f8-8_9

What could I do?... There are other guys telling that this combination works for them.


here are details:

Code:
root@backup:/usr/ports/www/nspluginwrapper on ttyp3
#:> make install
===>  Installing for nspluginwrapper-1.0.0
===>   nspluginwrapper-1.0.0 depends on file: /compat/linux/usr/lib/libgtk-x11-2.0.so.0 - not found
===>    Verifying install for /compat/linux/usr/lib/libgtk-x11-2.0.so.0 in /usr/ports/x11-toolkits/linux-gtk2
===>  Vulnerability check disabled, database not found
===>  Extracting for linux-gtk2-2.6.10
=> MD5 Checksum OK for rpm/i386/fedora/4/gtk2-2.6.10-2.fc4.4.i386.rpm.
=> SHA256 Checksum OK for rpm/i386/fedora/4/gtk2-2.6.10-2.fc4.4.i386.rpm.
=> MD5 Checksum OK for rpm/i386/fedora/4/gtk2-engines-2.6.3-2.i386.rpm.
=> SHA256 Checksum OK for rpm/i386/fedora/4/gtk2-engines-2.6.3-2.i386.rpm.
===>   linux-gtk2-2.6.10 depends on file: /usr/local/bin/rpm2cpio - found
===>  Patching for linux-gtk2-2.6.10
===>  Configuring for linux-gtk2-2.6.10
===>  Installing for linux-gtk2-2.6.10
===>   linux-gtk2-2.6.10 depends on file: /compat/linux/usr/lib/libglib-2.0.so.0 - not found
===>    Verifying install for /compat/linux/usr/lib/libglib-2.0.so.0 in /usr/ports/devel/linux-glib2
===>  Vulnerability check disabled, database not found
===>  Extracting for linux-glib2-2.6.6_1
=> MD5 Checksum OK for rpm/i386/fedora/4/glib2-2.6.6-1.i386.rpm.
=> SHA256 Checksum OK for rpm/i386/fedora/4/glib2-2.6.6-1.i386.rpm.
===>   linux-glib2-2.6.6_1 depends on file: /usr/local/bin/rpm2cpio - found
===>  Patching for linux-glib2-2.6.6_1
===>  Configuring for linux-glib2-2.6.6_1
===>  Installing for linux-glib2-2.6.6_1

===>  linux-glib2-2.6.6_1 conflicts with installed package(s):
      linux_base-f8-8_9

      They install files into the same place.
      Please remove them first with pkg_delete(1).
*** Error code 1

Stop in /usr/ports/devel/linux-glib2.
*** Error code 1

Stop in /usr/ports/x11-toolkits/linux-gtk2.
*** Error code 1

Stop in /usr/ports/www/nspluginwrapper.
root@backup:/usr/ports/www/nspluginwrapper on ttyp3
#:>
Code:
#:> uname -a
FreeBSD backup.hostname.com 7.1-PRERELEASE FreeBSD 7.1-PRERELEASE #0: Mon Dec  1 18:41:26 EET 2008     root@backup.hostname.com:/usr/obj/usr/src/sys/GENERIC  amd64
root@backup:/usr/ports/www/nspluginwrapper on ttyp3
need help ;)
10x in advance
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,954
Messages: 11,353

In my case, I had the nspluginwrapper and linux-glib installed before I installed linux-base. There were no problems there. So my suggestion is to deinstall linux-base first, install nspluginwrapper, and reinstall linux-base.
 
OP
edhunter

edhunter

Member

Reaction score: 10
Messages: 71

It worked... but I'm not sure if it is correct. Now i have two linux_base ports installed.
Code:
#:> pkg_info | grep linux
linux-atk-1.9.1     Accessibility Toolkit, Linux/i386 binary
linux-cairo-1.0.2   Linux cairo binary
linux-expat-1.95.8  Linux/i386 binary port of Expat XML-parsing library
linux-flashplugin-9.0r151 Adobe Flash Player NPAPI Plugin
linux-fontconfig-2.2.3_7 Linux/i386 binary of Fontconfig
linux-glib2-2.6.6_1 Version 2.X Linux/i386 binary port of GLib
linux-gtk2-2.6.10   GTK+ library, version 2.X, Linux binary
linux-jpeg-6b.34    RPM of the JPEG lib
linux-openssl-0.9.7f SSL and crypto library (Linux Version)
linux-pango-1.10.2  Linux pango binary
linux-png-1.2.8_2   RPM of the PNG lib
linux-tiff-3.7.1    TIFF library, Linux/i386 binary
linux-xorg-libs-6.8.2_5 Xorg libraries, linux binaries
[b]linux_base-f8-8_9   Base set of packages needed in Linux mode (for i386/amd64)
linux_base-fc-4_13  Base set of packages needed in Linux mode (for i386/amd64)[/b]
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,954
Messages: 11,353

I have the same, and everything works fine.

Interestingly enough:

Code:
# pkg_info -rR linux_base-f8-8_9
Information for linux_base-f8-8_9:

Depends on:
Code:
# pkg_info -rR linux_base-fc-4_13
Information for linux_base-fc-4_13:

Depends on:
Required by:
linux-atk-1.9.1
linux-cairo-1.0.2
linux-expat-1.95.8
linux-flashplugin-9.0r151
linux-fontconfig-2.2.3_7
linux-glib2-2.6.6_1
linux-gtk2-2.6.10
linux-jpeg-6b.34
linux-openssl-0.9.7f
linux-pango-1.10.2
linux-png-1.2.8_2
linux-tiff-3.7.1
linux-xorg-libs-6.8.2_5
nspluginwrapper-1.0.0
One would think that 8 is not required by anything ;)
 

Mel_Flynn

Well-Known Member

Reaction score: 81
Messages: 379

It isn't. Uninstalling linux_base-fc4 will be ugly as all md5 sums have changed. If you use pkg_delete -f, then your linux_base-fc8 will be nuked.

Have you guys set the OVERRIDE_LINUX_BASE_PORT=fc8 in /etc/make.conf?
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,954
Messages: 11,353

No, I haven't (package install anyway)
 

Mel_Flynn

Well-Known Member

Reaction score: 81
Messages: 379

Since when do packages allow conflicting packages to be installed?

Code:
$ make -C /usr/ports/emulators/linux_base-f8 -V CONFLICTS
linux_base-gentoo* linux_base-fc4 linux_base-fc6  linux_base-f7 linux-glib2

make -C /usr/ports/emulators/linux_base-fc4 -V CONFLICTS
linux_base-7* linux_base-deb* linux_base-gentoo*  linux_base-rh-9* linux_base-suse-9* linux_base-8*  linux_base-f8 linux_base-f7 linux_base-fc6 linux_locale*
Oh, to answer my own question:
cause some of those don't end with an asterisk. Smells like a workaround that should really be a bug.
 

aragon

Daemon

Reaction score: 280
Messages: 2,029

It looks like the linux-glib2 port was updated a few days ago. Previously it had broken CONFLICTS so this wasn't a problem at the time the article was written. Doing as suggested should be fine, but another option would be to edit the Makefiles of:

x11-toolkits/linux-gtk2
x11-toolkits/linux-pango
accessibility/linux-atk

And just remove the run dependency for linux-glib2. A newer version of linux-glib2 is installed by the linux_base-f8 port. That should prevent two linux_base ports from getting installed.

I think I will ping the -emulator guys and see if it's possible to get a better fix for this though.
 

aragon

Daemon

Reaction score: 280
Messages: 2,029

And I just noticed that the better fix has already been applied to x11-toolkits/linux-gtk2 a few days ago:

Code:
.if !defined(OVERRIDE_LINUX_BASE_PORT) || \
    (${OVERRIDE_LINUX_BASE_PORT} != "fc6" && \
    ${OVERRIDE_LINUX_BASE_PORT} != "f7" && \
    ${OVERRIDE_LINUX_BASE_PORT} != "f8")
RUN_DEPENDS+=	${LINUXBASE}/usr/lib/libglib-2.0.so.0:${PORTSDIR}/devel/linux-glib2
.endif
So the real fix for all of this is to make sure that OVERRIDE_LINUX_BASE_PORT=f8 is defined in /etc/make.conf.
 

contactmayankjain

New Member


Messages: 4

Flash is not working on my system after portupgrade. I have tried to install flash9 on freebsd using this recent guide http://crnl.org/blog/2008/11/01/flash-9-for-freebsd-71


and I am getting error message while running command nspluginwrapper -v -a -i
Auto-install plugins from /usr/X11R6/lib/browser_plugins
Looking for plugins in /usr/X11R6/lib/browser_plugins
Auto-install plugins from /usr/local/lib/npapi/linux-flashplugin
Looking for plugins in /usr/local/lib/npapi/linux-flashplugin
/usr/local/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory
Auto-install plugins from /root/.mozilla/plugins
Looking for plugins in /root/.mozilla/plugins
/usr/local/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory


I am using FreeBSD 6.3
uname -a
FreeBSD mayank.in.niksun.com 6.3-RELEASE FreeBSD 6.3-RELEASE #0: Wed Jan 16 04:45:45 UTC 2008 root@dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/SMP i386
 

contactmayankjain

New Member


Messages: 4

I am not able to install flashplugin7 even.

[root@mayank /usr/ports/www/linux-flashplugin7]# make install clean
===> linux-flashplugin-7.0r73_1 has known vulnerabilities:
=> linux-flashplugin -- multiple vulnerabilities.
Reference: <http://www.FreeBSD.org/ports/portaudit/78f456fd-9c87-11dd-a55e-00163e000016.html>
=> linux-flashplugin -- unspecified remote code execution vulnerability.
Reference: <http://www.FreeBSD.org/ports/portaudit/04c6187d-2d8f-11dd-98c9-00163e000016.html>
=> Please update your ports tree and try again.
*** Error code 1

Stop in /usr/ports/www/linux-flashplugin7/linux-flashplugin7.
*** Error code 1

I have tried updating ports but its already up to date.
 

cajunman4life

Active Member

Reaction score: 20
Messages: 119

No, there is no such workaround that I'm aware of.

If you want to follow the guide and get flash working, you'll need to update to at least the 7-STABLE series.
 
Top