Can install 10.3 to 11.1 but not 11.2 to 13

vmb

New Member

Reaction score: 3
Messages: 14

I am repurposing a 10Zig Linux thin client terminal that has a dual core 64-bit intel atom with AES-NI, but I cannot install any version of FreeBSD beyond 11.1-RELEASE .

I have tried every version in memstick form, 10.3, 10.4, 11.0, 11.1 which all install successfully and the installed system can boot ZFS on root afterwards. I have had no problems with these versions on this device other than they are all unsupported now.

However, I cannot install 11.2, 11.3, 12.0 or 13-CURRENT from either memstick or from DVD. In all cases the install program gets as far as loading the kernel syms then the spinner stops. Keyboard caps-lock and num-lock LEDs can still be toggled successfuly afterwards with the stuck spinner. Also, when installing from DVD, the drive still appears to be seeking on and off for five minutes or so. I have left it for hours hoping the install would continue but it never does. The machine has to be powered down.

Errors observed:
11.2 - Displays 'Booting...' in early stage of booting installer then spinner stops.
11.3 - Displays 'Booting...' in early stage of booting installer then spinner stops.
12.0 - Kernel loads syms then displays 'can't find /boot/entropy' then spinner stops.
13.0 - Kernel loads syms then displays 'can't find /boot/entropy' then spinner stops.

I tried booting with ACPI option switched off but the machine refuses to boot. I didn't record the error.
I have tried amd64 media for all of the stated versions, and i386 for 10.3, 11.2 and 12.0 with the same outcomes as the amd64 versions.

The machine has UEFI but is currently configured to run in legacy BIOS mode.
The machine has eMMC onboard but I have disabled it in BIOS. I will be installing to an internal mSATA SSD later, installing to a USB hard drive for testing.
I have tried every combination of UEFI/BIOS setting but still get the same outcome, 11.1 or earlier installs, 11.2 or later fails.

What kernel changes have been made between 11.1 and 11.2 that could prevent FreeBSD from being installed?
Was the release version of 11.2 compiled with the exact same options as 11.1?
I am hoping a custom kernel will resolve the problem but I am wondering if this is something to do with a patched cpu vulnerability.
 

Attachments

Phishfry

Son of Beastie

Reaction score: 1,526
Messages: 4,434

Have you tried falling back to the old console sc(4) ?
I am assuming you can get to the loader screen, hit #3 and boot to loader prompt.
Type this and see if you get anywhere:
set kern.vty=sc
boot
 
  • Thanks
Reactions: vmb

Phishfry

Son of Beastie

Reaction score: 1,526
Messages: 4,434

For vt(4) there are some settings to try as well. Most notably from #3 - loader prompt:
set hw.vga.textmode=1
boot
 
  • Thanks
Reactions: vmb
OP
OP
V

vmb

New Member

Reaction score: 3
Messages: 14

I have just been reading the release notes for 11.2 and spotted that there was a fix applied for boot issues with Intel® Apollo Lake™ CPUs.

The Intel Atom® Processor E3825 in my machine is a 'Bay Trail', so presumably was originally unaffected in 11.1 kernel code. Perhaps this kernel fix has had an unintended consequence (just guessing) for similar earlier intel cpus?

I am thinking that if I manually patch the kernel source for 11.1 with this fix and build a custom kernel to test I will be able to eliminate this issue or not. For some strange reason I could not perform a freebsd-update fetch on a July 2019 installed OS. It consistently failed to download 1 file. I don't know what the 1 file was, but it was the only installed FreeBSD on this machine that could not be updated to a patched release.
 
OP
OP
V

vmb

New Member

Reaction score: 3
Messages: 14

Thanks Phishfry, will try both of your suggestions. I already use hw.vga.textmode=1 on repurposed Dell FX130
 
OP
OP
V

vmb

New Member

Reaction score: 3
Messages: 14

Success!

For the 11.2 installer using the kernel option set kern.vty=sc worked perfectly to enable the system to be installed.

I also had to put kern.vty=sc in /boot/loader.conf to get the installed system to boot. The other setting, hw.vga.textmode=1 doesn't perform sufficient magic to enable the installed system to boot so unless I have any issues with other LCD display monitors I will just leave it out for the time being.
 
Top