can I live without ACPI or don't?

Hi people :)

Hope to be the right place to ask this, I was using FreeBSD 6.1-px for more than a year, everything was good, my ACPI was working, "shutdown -p now" work for me, etc, etc.

Them I decide to migrate my server to 7.0 Release, my computer is old Foxconn KM400 Duron 1.6Ghz, here I run my backup server with bacula Raid-1 with gmirror. I migrate because I will run a app with mysql 5.1, before I was using mysql 4.1.

I prefer to migrate to 7.0 because everything point to this branch.

Everything is working, but I start getting this annoying messages:

kernel: acpi_tz0: _TMP value is absurd, ignored (-247.7C)

Them start googling, but a lot of threads without a solution, maybe my BIOS is old, foxconn doesn't have any update for my motherboard:

acpi0: <KM400 AWRDACPI> on motherboard

Well I just disable ACPI inside my BIOS or went freebsd boots, but I prefer to leave my ACPI disable in the BIOS.

I know that I will cannot shutdown my server without my intervention, but those message really put nervous.

Doing this, affect the performance of my OS(FreeBSD) or is just a feature that we can live without:q

Is all my doubts, thanks for you time.

FreeBSD 7.0-RELEASE-p5
Motherboard Foxconn KM400 i386 512RAM.
Custom Kernel but using almost the settings as before FreeBSD 6.1-px.
 
can you try some linux live cd to see if your kernel message is being shown on linux as well?
maybe it's your bios problem, maybe it's FreeBSD bug.


I believe you can disable acpi (there shouldn't be any problems with that)
btw, when you boot FreeBSD you should pick 2nd option (you might want to edit loader config files, so that you don't have to select 2nd option every time)

I suggest you make sure you don't have acpi in kernel config. I'm not sure if FreeBSD won't use acpi if you disabled in BIOS, but still run FreeBSD with acpi.

TZ is Thermal zone, which is heat related. Make sure your ventilation is good (just make sure, we don't want smoke, don't we)
 
I've seen some regressions in ACPI in 7.0, which gradually got fixed towards where we are now.
It is worth investigating whether 7.1-BETA2 has these problems as well and report it if so. Be sure to mention that 6.3 on the same machine has a correct thermal zone.
A verbose boot and pciconf -lv output are the basics to post with ACPI problems. And of course, sysctl hw.acpi output.
 
If that message is the only message you get, it's not really a problem - it just means one of the temperature sensors are giving wonky data.
 
Djn said:
If that message is the only message you get, it's not really a problem - it just means one of the temperature sensors are giving wonky data.

Or sensors data are interpreted wrong
 
Myeah, that's probably more likely.
(In my defense, if you define "temperature sensor" as the sysctl and not the hardware, it's right either way. ;) )
 
My first assumption was on the form "buggy ACPI code/BIOS gives weird values, but it's been ignored up to now", which is neither here nor there. I guess I could have formulated it better.
 
It can be faulty BIOS.
Post output of:
Code:
# sysctl hw.acpi.thermal.

Message probably means that such sensor as defined in BIOS is not present.

I had similar problem.*I fixed it dumping ACPI asl and changing it, I found few typos :D After that I recompiled it and use that one instead of BIOS one.

Read 11.16 Using and Debugging FreeBSD ACPI inside FreeBSD Handbook.
 
Mel_Flynn said:
Unless a major version OS upgrade changes hardware, there's no reason to suspect it's a faulty sensor.

There's also no reason to suspect that there is a temperature of -247.7 degrees celcius inside this computer :)

It could be a faulty sensor, or a problem with interpretation.. but the latter only seems sensible if the problems started after a OS upgrade.

@klabacita: I wouldn't worry too much about these messages. As the message shows, the measured temperature is absurd so it's ignored. It'd be wise to check the temperatures inside of your computer though (just check for uncomfortably hot heatsinks etc.).
 
Thanks all of u for your great amount of information.

I will try to debug this week, my main say maybe from 6.1 to 7.0 something change, but I won't say anything until I run some test.

Right now I disable my ACPI inside my BIOS and FreeBSD stop sending this messages.

I still have the disk with 6.1-px running I will check my kernel config file and compare with my current system.

This machine like I say before run 6.1-px without any issues with the ACPI.

"richardpl"
Message probably means that such sensor as defined in BIOS is not present.

Maybe u are right ;)

I will let u know people my result as soon as I receive this info.

Thanks again!!!
 

trasz@

Developer
You can selectively disable parts of ACPI. In this case, it would be 'debug.acpi.disabled="thermal"' in your /boot/loader.conf.
 
But could that make it risky from overheating not being noticed early?

_CRT is just for that - FreeBSD ACPI will shutdown system when that temperature is reached.
 

trasz@

Developer
Well, in this case the thermal sensor - or the ACPI interface to that sensor - is obviously malfunctioning, so I don't think FreeBSD is gonna make much use of it.
 
I actually have a machine with the same problem under 7.1-BETA2. Via chipset with AMD i386 processor. Can't debug right now, as it's replacing a machine out for repair, but after that it's my new playmate.
 
Hi people.

After some test I still cannot confirm is this warning message, is something new that appear in FBSD 7 or my BIOS is crapy. But with FBSD 6.1 was working.

I can confirm that my thermal zone is good and my server room is cold as a beer, because my BIOS screen give me the right info of my CPU temp.

I cannot test to much because this machine need to work.

What I did was to disable the thermal module as @trasz suggest and those message dissapear.

Hope latter to have a litle more time to test this and see If i could find out the problem.

Thanks all for your great support and tips, my messages are gone �e.

Thanks again.
 
Top