Can I access website via proxy with Epiphany?

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,290
Messages: 29,742

You configure the proxy in Gnome, not in Epiphany.
 
OP
OP
masayoshi

masayoshi

Member

Reaction score: 7
Messages: 96

I have installed FreeBSD 7.4 for test now.
I could access website via proxy server with Epiphany.
But,I can not access website via proxy server with Epiphany on FreeBSD 8.2.

Code:
$ uname -r
7.4-RELEASE-p3
$ pkg_info | grep epiphany
epiphany-2.30.6_1   An extremely lightweight and simple web browser for GNOME 2
$ pkg_info | grep gnome2
gnome2-2.32.1_1     The "meta-port" for the GNOME 2 integrated X11 desktop
 

Beeblebrox

Aspiring Daemon

Reaction score: 147
Messages: 985

1. Is your proxy running? If not stop & start it. If you get service not running, there's your problem.
# lsof -i :8080
# service <name> onestop
2. Most proxies have an internal web page. Can you access it from browser? (something like localhost/<proxypage>). For example privoxy:
Privoxy's user interface can be reached through the special URL http://config.privoxy.org/ (shortcut: http://p.p/), which is a built-in page and works without Internet access
3. Do you have another service running after the proxy (like tor)? If the proxy is running but tor is not => no access.
 
OP
OP
masayoshi

masayoshi

Member

Reaction score: 7
Messages: 96

Beeblebrox said:
9.0-RC1 - gcc46 - root on zfs - amd64
Thank you for answering my question.
As you use 9.0-RC1, I tested on 9.0-RC1.

version : epiphany-2.30.6_2

Sorry, perhaps, I can access website via proxy.
Perhaps .......
Epiphany ignore "header_replace User-Agent TAG " in my squid.conf?



I really appreciate your help.
 

Beeblebrox

Aspiring Daemon

Reaction score: 147
Messages: 985

Gnome-Network-Proxy works by adding a Gnome variable into environment. Check if this variable is being defined correctly - # env will print out all defined csh and gnome environment variables. Look for something like "NETWORK_PROXY". You can also define this globally from /etc/profiles or /etc/csh.cshrc. Test if the defined environment variable is working and if not, why.
 
OP
OP
masayoshi

masayoshi

Member

Reaction score: 7
Messages: 96

Beeblebrox said:
Gnome-Network-Proxy works by adding a Gnome variable into environment. Check if this variable is being defined correctly - # env will print out all defined csh and gnome environment variables. Look for something like "NETWORK_PROXY". You can also define this globally from /etc/profiles or /etc/csh.cshrc. Test if the defined environment variable is working and if not, why.

Code:
$ env | grep "192.168.0.2:8080"
HTTP_PROXY=http://192.168.0.2:8080/
http_proxy=http://192.168.0.2:8080/
FTP_PROXY=http://192.168.0.2:8080/
all_proxy=socks://192.168.0.2:8080/
HTTPS_PROXY=http://192.168.0.2:8080/
https_proxy=http://192.168.0.2:8080/
ALL_PROXY=socks://192.168.0.2:8080/
ftp_proxy=http://192.168.0.2:8080/
It is very difficult for me to use Epiphany. >_>
 

Beeblebrox

Aspiring Daemon

Reaction score: 147
Messages: 985

Code:
all_proxy=socks://192.168.0.2:8080/
Don't use socks with ftp - compromises socks. But ftp can go through squid without problem.

When you start epiphany from cli (command-line) what are the messages?
 
OP
OP
masayoshi

masayoshi

Member

Reaction score: 7
Messages: 96

Beeblebrox said:
Don't use socks with ftp - compromises socks. But ftp can go through squid without problem.

When you start epiphany from cli (command-line) what are the messages?
Code:
> epiphany &
[1] 3007
> ** (epiphany:3007): DEBUG: NP_Initialize
** (epiphany:3007): DEBUG: NP_Initialize succeeded
** (epiphany:3007): DEBUG: NP_Initialize
** (epiphany:3007): DEBUG: NP_Initialize succeeded

(process:3019): Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "gnomesegvhandler": libgnomesegvhandler.so: cannot open shared object file: No such file or directory
** (epiphany:3007): DEBUG: NP_Initialize
** (epiphany:3007): DEBUG: NP_Initialize succeeded
** (epiphany:3007): DEBUG: NP_Initialize
** (epiphany:3007): DEBUG: NP_Initialize succeeded
openjdk version "1.6.0"
OpenJDK Runtime Environment (build 1.6.0-b23)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)

I usually access the following website to check my proxy setting.
http://taruo.net/e/

If I access there via proxy , my HTTP_USER_AGENT is "My original browser"
So I can see this message with firefox.
But If I use Epiphany,
It is Mozilla/5.0 (X11; FreeBSD amd64) AppleWebKit/534.26+ (KHTML, like Gecko) Version/5.0 Safari/534.26+ Epiphany/2.30.6
I reckon Epiphany ignore proxy.
 

Beeblebrox

Aspiring Daemon

Reaction score: 147
Messages: 985

Don't use socks with ftp - compromises socks
That's a silly comment, I must have had my head in a soup bowl or something. What I meant to say is: When using socks, make sure all protocols go through socks (ftp included). Don't just torrify/sockify http, because a site may send data to the browser through ftp and compromise socks. Even proxy buttons (like foxyproxy and such) are not recommended. What I do is I have one browser (or separate profile of the browser) completely dedicated to socks setting, and the other browser as non-socks or normal. There's a good discussion about this on Tor site.

Epiphany: I'm out of suggestions there <EOF>
 
Top