• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Buildworld stuck on clang

CraigHB

Member

Thanks: 24
Messages: 90

#1
I'm trying to do a buildworld right now and it's taking a really long time. It's been stuck on libllvm for about an hour now. If I understand correctly that's part of clang. Is there an option I can use to speed it up like telling it not to build the debugging stuff?
 

Snurg

Aspiring Daemon

Thanks: 325
Messages: 794

#2
AFAIU all stuff gets built with debug symbols and gets stripped with objcopy after building. (Please correct me if I am wrong)

Maybe this tip of Eric A. Borisch is useful to you, too...
(You'll have to have the filemon kernel module loaded to make it work speeding up, do kldload filemon before the build run)
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,097
Messages: 26,989

#4
I'm trying to do a buildworld right now and it's taking a really long time.
It's a rather lengthy process. And it really depends on the machine how long it's going to take. My Core i5 server takes a little over 2 hours to build world, on my dual Xeon it takes less than an hour, on a Raspberry Pi it'll take 2 days.
 

CraigHB

Member

Thanks: 24
Messages: 90

#5
It ended up taking about four hours. Surprising to me, everything I've done before builds pretty quick, but it's an old machine. Anyway, I'm probably not going to do a buildworld very often if at all. Mainly did it to see if it has any effect on some warnings I'm seeing with a kernel build (another topic). Wanted to see if doing a buildworld first made any difference.
 
Top