BTX halted on boot

I have tried installing multiple releases of BSD (7.0, 6.3) even including FreeNAS and NETBSD with all producing the exact same BTX halted message.

Code:
int=0000000d err=00000000 efl=00010086 eip=0002205c
eax=80000011 ebx=00000000 ecx=c0000080 edx=00000000
esi=00000200 edi=0006f748 edp=000948ac esp=000093fa
cs=0008  ds=0010  es=0010  fs=0010  gs=0010 ss=0010
cs:eip=0f 22 c0 b8 00 d0 03 00-8b 35 58 2f 04 00 8b 3d
       5c 2f 04 00 0f 01 10 ea-7a 20 02 00 08 00 89 f0
ss:esp=36 80 0d 07 90 00 00 01-e9 cb fc ff ff aa ac 84
       c0 0f 84 86 00 00 00 a8-80 74 f2 88 c5 b0 3d aa
BTX halted

I have validated the checksum and burned this on multiple burners with no difference.

There is a little information around on the net mostly pointing to BIOS settings. Disabling the ULTRA DMA mode on both the cd and hard drive did not resolve the issue. manually setting the MODE to LBA and off for both the hard drive and the cd-rom. I have been able to reproduce this on both my computers.

machine 1:
Asus A7V-333
AMD Athlon Xp 1900+
2x512 ddr
200gb Maxtor HD ATA-133

machine 2:
GIGABYTE GA-P35-DS3L
Intel Core 2 Duo E6750
4x1gb
2x500 SATA 500gb Western Digital

Both machines have updated Bios..... Out of ideas over here... Anyone run in to anything like this?
 
it's happen to me, like two years ago, but it happens in a AMD k6-II 550 mhz (it's my favoriteof the 5 desktops i have in home :e) i just tried to install Freebsd 4.x and i change from it to 5.x i386 and it just work...

never guess why it happens, but someone told me to read the hardware compatibility. and chek it on the FreeBSD versions.

i know it's not a solution, but maybe you should see them too.

(sorry about my english)
 
Yes, many have ran into this. The cause is a lack of emulation of certain i386 "real mode" instructions by FreeBSD, which runs in "i386 protected mode". IIRC this should have been fixed in 7.2 ;)
 
Back
Top