1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BSD on Sun Netra X1

Discussion in 'Other Architectures' started by NoobFred, Jul 17, 2010.

  1. NoobFred

    NoobFred New Member

    Thanks Received:
    I got a hold of a pair of identical X1s for a case of Becks dark. So here I am trying to load BSD on them. I dled the latest version here for sparc 64 and burnt the iso to cd.

    Put in an 80 gig drive jumped to master into the #1 position in the box. Added a cdrom to position 2 jumped to slave. powered it up and tried to get it to boot from cdrom by the boot cdrom at the lom.

    Got this message
    lom>boot cdrom
    Usage: bootmode [[-u] forth|reset_nvram|diag|skipdiag|normal]

    While the server was booting up I got this message before I tried to specify the boot path.
    Bad magic number in disk label
    Can't open disk label package
    Boot device: net  File and args:
    Link hasn't comeup yet.
    Will try to communicate anyway.
    Network Link Setup Failed.
    Please Check Cable and Try Again.

    I am not worried about the network link setup yet, I will deal with that later. But I am wondering why I cannot get it to boot from cdrom to load BSD onto the drive.

    The reason I am starting a new thread on this is that I wish to keep all correspondence in one place. I did look at these places for info but I keep getting the same messages when I try to boot from cdrom.




    I thank any who respond in advance for taking your time to help me with this
  2. NoobFred

    NoobFred New Member

    Thanks Received:
    Did a probe with probe-ide-all and came up with this result.
    ok probe-ide-all
      Device 0  ( Primary Master )
              ATA Model: ST3120026A
      Device 1  ( Primary Slave )
             Not Present
      Device 2  ( Secondary Master )
             Removable ATAPI Model: SONY    CD-RW  CRX225E
      Device 3  ( Secondary Slave )
             Not Present

    So the drives are correct it appears and they are recognized by the box.
    I am kinda at a loss what to do as my next step. I am open for suggestions.
  3. tingo

    tingo Active Member

    Thanks Received:
    So what does 'devalias' say? Is "disk" and "cdrom" aliased to the correct devices?
    Another thing, have you reset the OBP to default values after you got the machines? If not, try that.
    Third suggestion; have you verified that the CD-ROM actually works? Can you boot anything else from it?
  4. mmoll

    mmoll New Member

    Thanks Received:
    You need to execute the boot command at the OBP ('ok' prompt), not at the LOM.
  5. druid628

    druid628 New Member

    Thanks Received:
    For what it's worth, when I did my install on my X1 I had a similar problem my solution was really unusual (to me). I could NOT use anything but CD-ROM only, no CD-R/RW no DVD/CD-RW just a plain-jane cd-rom. When I did that it worked.

    I hope this helps!