Brother HL-2040 and cups 1.4.2

atomicplayboy

Member

Reaction score: 4
Messages: 76

Hello all,
Recently the cups version in ports was updated from the 1.3 series to the 1.4. Unfortunately my printer (Brother HL-2040) no longer works after the update. I recall it was a burden to set up originally, but now simply a test page from the web administration interface just hangs at, "processing," as the printer remains mute.

I have it hooked up via USB (/dev/unlpt0) using the foomatic hl1250 driver which always worked splendidly enough in the past. I've attempted removing this entry and adding a new printer, but the web interface doesn't detect any local printers, nor does it allow me to manually select where my device is hooked up. Restoring the old version of cups has allowed me to continue to use my printer, but I'm at a loss as to how to proceed with the new version. Thanks in advance for whatever help anyone can give me.
 

roddierod

Aspiring Daemon

Reaction score: 145
Messages: 833

CUPS is on of the things that I think really applies to the rule, "if it ain't broke, don't fix it." Too many time in the past CUPS "upgrades" have broken things and they just never work again. If you really don't NEED to upgrade, don't.

Cups is one of the few things I have in my pkgtools.conf file in the HOLD_PKGS.

I'm using a Brother HL-4040CDN and have had CUPS on hold for about a year since it's working.

Just a suggestions.
 

plamaiziere

Active Member

Reaction score: 40
Messages: 184

atomicplayboy said:
Hello all,
Recently the cups version in ports was updated from the 1.3 series to the 1.4. Unfortunately my printer (Brother HL-2040) no longer works after the update. I recall it was a burden to set up originally, but now simply a test page from the web administration interface just hangs at, "processing," as the printer remains mute.
Looks like cups is broken (who said again?) with usb printers. For me, it hangs in the usb backend (using unlpt0 on FreeBSD 8).

I don't have the time to search why. I suggest you to report this issue.
 
OP
OP
A

atomicplayboy

Member

Reaction score: 4
Messages: 76

Should I submit a PR? Any suggestions on what information I should include? I've never actually submitted a PR before...
 

plamaiziere

Active Member

Reaction score: 40
Messages: 184

atomicplayboy said:
Should I submit a PR? Any suggestions on what information I should include? I've never actually submitted a PR before...
You can ask on the ports@ mailing list. Please include your FreeBSD version, the version of cups (ie pkg_info) and any information that could be useful (cups logs,...)
 

bjs

Member

Reaction score: 8
Messages: 56

Just checked the CUPS port and seems there's been another update to v. 1.4.2_1. So maybe it had been fixed now.
 
OP
OP
A

atomicplayboy

Member

Reaction score: 4
Messages: 76

Haven't gotten around to reporting this yet, but I did try the new revision bump. A LIBUSB option was added "for USB support," but selecting the option just attempts to build the libusb port, which fails on FreeBSD 8, seeing as how it was obsoleted by builtin support.
 
OP
OP
A

atomicplayboy

Member

Reaction score: 4
Messages: 76

A fix was committed according to this PR. I updated my cups ports and all is working and well using my existing configurations. Thanks for all the advice.
 
Top