Bridging Problems

UnixUser

New Member


Messages: 3

I have two FreeBSD boxes, one for server tasks (ftp, Apache, etc..) and the other for a desktop system.
I have a router that connects to the server and have been using a bridge to connect other machines to the router through the server. I set this up following the FreeBSD handbook Bridging guide, so my rc.conf now reads:
Code:
cloned_interfaces="bridge0"
ifconfig_bridge0="addm rl0 addm nfe0 up"
ifconfig_rl0="up" #connected to device in room
ifconfig_nfe0="up" #connected to router

ifconfig_nfe0="DHCP"


I have been able to connect both my Xbox and Windows 7 laptop to the internet through this bridge, but it does not work anytime I connect a FreeBSD based machine to it(I have used both PC-BSD and plain FreeBSD).

Do I need to add:
Code:
gateway_enable="YES"

to my rc.conf on the server? I would like to just have my main router assigning the IP's so I don't think that is what I want.

One last thing, dhclient rl0 on the server and dhclient fxp0 on the desktop both return:
Code:
no link......

but I am using the same cable that I used to connect successfully to my Win 7 box.

Any help would be greatly appreciated. Thanks!
 

aragon

Daemon

Reaction score: 281
Messages: 2,029

UnixUser said:
Code:
cloned_interfaces="bridge0"
ifconfig_bridge0="addm rl0 addm nfe0 up"
ifconfig_rl0="up" #connected to device in room
ifconfig_nfe0="up" #connected to router

ifconfig_nfe0="DHCP"
This is incorrect. Do not enable the DHCP client on your real interfaces. Enable it on the bridge0 interface. Your config should be changed to:

Code:
cloned_interfaces="bridge0"
ifconfig_bridge0="dhcp addm rl0 addm nfe0 up"
ifconfig_rl0="up" #connected to device in room
ifconfig_nfe0="up" #connected to router



UnixUser said:
I have been able to connect both my Xbox and Windows 7 laptop to the internet through this bridge, but it does not work anytime I connect a FreeBSD based machine to it(I have used both PC-BSD and plain FreeBSD).

Do I need to add:
Code:
gateway_enable="YES"

to my rc.conf on the server? I would like to just have my main router assigning the IP's so I don't think that is what I want.
No.


UnixUser said:
One last thing, dhclient rl0 on the server and dhclient fxp0 on the desktop both return:
Code:
no link......

but I am using the same cable that I used to connect successfully to my Win 7 box.
Again, do not run dhclient on rl0 of the server. The "no link..." error means your network cards are not linking. This is a hardware problem. It sounds like you need a crossover cable. Your other two PCs' network cards probably support AutoMDIX, so don't need a crossover cable. (but will work with one too)
 
OP
U

UnixUser

New Member


Messages: 3

Thanks. I thought it might have something to do with not having the correct cable, but I just couldn't figure out why in the world the other computers worked, but AutoMDIX explains that. I changed around my /etc/rc.conf file and all seems to be working. Now I just need to find/make a cross over cable.......
 
Top