Braswell and FreeBSD 11.2

joachin

Member


Messages: 30

#1
Hey guys, does FreeBSD support Braswell GPU? When I did a install with FreeBSD 11.2 and installed next-kmod and added to rc.conf, then rebooted, I had a black screen, can you tell me if it's supported please?

Thanks!
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,516
Messages: 27,956

#2
Build the graphics/drm-next-kmod from ports and it should work. The reason is that the official packages are still built for 11.1 and don't work on 11.2. This will eventually be "fixed" when 11.1 is EoL and packages get built for 11.2.
 

k.jacker

Well-Known Member

Thanks: 237
Messages: 453

#6
Braswell is supported (though if ALL processors of the series are supported isn't guaranteed)

Have you installed a Xorg already and start some DE through a desktop login manager?

If that's the case, then you should disable loading of the i915kms (graphics/drm-next-kmod)driver and the start of the desktop manager in /etc/rc.conf. Then reboot.
When FreeBSD is up, load the driver by hand # kldload /boot/modules/i915kms.ko and see what happens. You should see messages from the driver attaching and registering the video outputs and stuff. The screen shouldn't go black.

Then start your desktop manager. For x11/slim that would be service slim onestart
(kdm and gdm for KDE and Gnome I think, but not sure)
If the screen goes blank now, I bet you have something wrong in your xorg.conf.
The easiest way to check that, is to simply move the file to some other place and let Xorg autoconfigure itself when it starts. Works very well.
 

shepper

Aspiring Daemon

Thanks: 246
Messages: 737

#7
Even with a black screen, a /var/log/Xorg.0.log will be written, saved and available on reboot. The log should provide useful info.
 
OP
OP
J

joachin

Member


Messages: 30

#9
Braswell is supported (though if ALL processors of the series are supported isn't guaranteed)

Have you installed a Xorg already and start some DE through a desktop login manager?

If that's the case, then you should disable loading of the i915kms (graphics/drm-next-kmod)driver and the start of the desktop manager in /etc/rc.conf. Then reboot.
When FreeBSD is up, load the driver by hand # kldload /boot/modules/i915kms.ko and see what happens. You should see messages from the driver attaching and registering the video outputs and stuff. The screen shouldn't go black.

Then start your desktop manager. For x11/slim that would be service slim onestart
(kdm and gdm for KDE and Gnome I think, but not sure)
If the screen goes blank now, I bet you have something wrong in your xorg.conf.
The easiest way to check that, is to simply move the file to some other place and let Xorg autoconfigure itself when it starts. Works very well.
No, I can't loging, I can't see a graphic mode.
going to do that thanks!
 
Top