Bootonly: FTP permission denied


I'm facing a little issue with the bootonly installation of FreeBSD. I'm using an ISO that I downloaded on the official FreeBSD FTP.
I configured my WAN adapter bge0 with outside access, it's working great during the install, I can ping any internet address.
I configured my DNS, that's working too, it resolves correctly the address I'm typing.

The issue is :
After the partitioning of my disks, when the installer connects to the FreeBSD ftp to download base.txz, it prints the message:
Error while fetching[...]base.txz : permission denied
(of course, the [...] is the complete path in the installer).

I tried to switch to a virtual console (Alt+F4) and did the following in order to test:

> ftp
It gives the following output :
ftp : Can't connect to '' : Permission Denied
ftp : Can't connect to'

Of course, I tried with a large amount of mirrors and none of them is working, it gives me the same error message. I also tried to connect to the ftp from another server in the same network, with the same router/gateway, and it's working great.

Any idea guys?

Thanks :)