Bootloader on Raspberry Pi doesn't clear screen

oitdmser

New Member

Reaction score: 1
Messages: 14

Running the FreeBSD 12 Release on the Raspberry Pi. In /boot/loader.conf I changed beastie_disable to "NO" so I would get the boot menu. As shown in the image below, the bootloader doesn't clear the screen and it's very difficult to see what's going on.

Did I do something wrong? Is this a bug? Where is this info documented?
IMG_6106.jpg
 

johnblue

Well-Known Member

Reaction score: 42
Messages: 317

oitdmser said:
In /boot/loader.conf I changed beastie_disable to "NO" so I would get the boot menu.
Sooo. oitdmser.

:D

Is "NO" a typo? The man page for /boot/loader.conf only gives "YES" as an option to get to the boot menu.
 
OP
OP
O

oitdmser

New Member

Reaction score: 1
Messages: 14

"NO" is not a typo. The default is beastie_disable="YES" which boots without a menu.

In my testing I have found either of the following have the result illustrated in the OP:

beastie_disable="NO"
#beastie_disable="YES"
 

ComradeSlice

Member

Reaction score: 9
Messages: 66

I have the same issue :)

Try these:
boot_multicons="YES"
beastie_disable="YES"
loader_color="NO"
 
OP
OP
O

oitdmser

New Member

Reaction score: 1
Messages: 14

I have the same issue :)

Try these:
boot_multicons="YES"
beastie_disable="YES"
loader_color="NO"
I appreciate your suggestion, but I need the boot menu so I can select single user mode if needed. Disabling beastie disables the necessary boot loader
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,389
Messages: 29,953

It doesn't disable the boot loader, just the menu. You can still interrupt loader(8) and enter boot -s to boot to single user mode. You may also want to take a look at the nextboot(8) command.
 

Phishfry

Son of Beastie

Reaction score: 1,287
Messages: 3,778

I see 64bit EFI and aarch64.
You have a RaspberryPi 3 right?
 
Top