Solved Booting 13.1 error

SteveG1

Member

Reaction score: 2
Messages: 22

Hi,

This is on an X5000 (powerpc64 book3e - no altavec), so binaries are not available from downloads.freebsd.org. I was able to get some binaries from someone and they are working on their system, but on mine when I try to boot I get:
Code:
## Starting application at 0x00010160 ...
Consoles: U-Boot console  
Compatible U-Boot API signature found @0x7fe2efd8

FreeBSD/powerpc64 U-Boot loader, Revision 1.1

Number of U-Boot devices: 4
U-Boot env: loaderdev='disk1s2a'
Found U-Boot device: disk
  Checking unit=1 slice=2 partition=0... good.
Bad trap at PC: 0, SR: 1200, vector=800
NIP: 00000000 XER: 00000000 LR: 0001283C REGS: 7fe2d910 TRAP: 0800 DAR: 00000000
MSR: 00001200 EE: 0 PR: 0 FP: 0 ME: 1 IR/DR: 00

GPR00: 00049D00 7FE2DA00 7FE2DF00 7FE2DA10 00060640 7FE2DA30 00000000 00000010
GPR08: 000606F8 00000000 00000000 00060680 00000100 B2008A10 0005C248 00000000
GPR16: 0005C014 00000002 00000000 0005D768 00059E98 00059C9F 000594D9 0005A425
GPR24: 0005C020 0005C024 00060000 00000000 00060640 00000000 000606C0 00000000
Call backtrace:
00041810 00049D00 0004F170 00049440 00014264 0003413C 0003EA64
0002249C 7FF45B64 00000000 7FE8C438
Exception in kernel pc 0 signal 0
### ERROR ### Please RESET the board ###
Does anyone have any ideas on what is causing this?

Thanks!

SteveG
 

Alain De Vos

Son of Beastie

Reaction score: 995
Messages: 3,073

You should ask someone who create some binaries for something how exactly they where created and that might give you some ideas for some of the problems.
 

Phishfry

Beastie's Twin

Reaction score: 3,236
Messages: 6,372

UBoot can be temperamental about memory amounts. It is programmed in with the build on some platforms.
Have you tried to escape to the U-boot command prompt and do a memory check?
I have a feeling that Memory is at play here.
Are you using the same amount of memory as the person you got the help from?
 
OP
S

SteveG1

Member

Reaction score: 2
Messages: 22

Yes, the issue was with ubldr. Putting in one from an older install fixed the issue. Thank you!
 
Top