Boot Menu Logos

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

On my old tyan server and on my lenovo laptop, the boot menu comes up with the nice new shiny graphics logos.

But on my new supermicro box (does have an nvidia) the boot menu comes up with the old ascii art logos.

Why?

logo1.jpg


logo2.jpg
 

olli@

Daemon
Developer

Reaction score: 1,255
Messages: 1,140

I guess it’s because the Nvidia GPU doesn’t have a VESA BIOS extension, which is required by the boot loader to use graphics mode.
See the description of the screen.textmode setting in the loader.conf(5) manual page.

By the way, are you booting via EFI or via CSM (legacy BIOS)? I think that the loader might be able to use the EFI framebuffer for graphics, but I’m not sure. I really don’t pay much attention to the boot screen and don’t care much about it.

If you’re not sure which way your system uses for booting, type sysctl machdep.bootmethod at a shell prompt. It will print either “UEFI” or “BIOS”.
 
OP
Geezer

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

I guess it’s because the Nvidia GPU doesn’t have a VESA BIOS extension, which is required by the boot loader to use graphics mode.
See the description of the screen.textmode setting in the loader.conf(5) manual page.

Yes.

By the way, are you booting via EFI or via CSM (legacy BIOS)? I think that the loader might be able to use the EFI framebuffer for graphics, but I’m not sure.

EFI
 

mer

Aspiring Daemon

Reaction score: 339
Messages: 552

If nvidia GPU, once you are in X, you can have trouble switching to another virtual console and switching back, so
on my systems with nvidia I have:
hw.vga.textmode="1"
in /boot/loader.conf

I'm not sure how or if that would play into EFI boot or with the other framebuffer stuff, but figured I'd point it out.
As for the boot menu graphics, I'm used to the ASCII art and I don't boot very often, so I'm ok with it :)
 
OP
Geezer

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

Thank you mer and olli@ .

screen.textmode did not make a difference.

After rebooting a couple of times and thinking about it, in some ways it is better all as ascii, especially if I want to control it remotely. The KVM does not work past the boot menu with a non-integrated graphics card, but the SOL is very good, and text only.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,370
Messages: 38,906

Force textmode off if you want to see the graphics.

Code:
hw.vga.textmode="0"
 
  • Like
Reactions: mer

Emrion

Aspiring Daemon

Reaction score: 221
Messages: 681

If you had a previous installation of FreeBSD on your Supermicro (say 12.x), you need to update the efi bootloader to have the graphic version of the boot menu.
 
OP
Geezer

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

If you had a previous installation of FreeBSD on your Supermicro (say 12.x), you need to update the efi bootloader to have the graphic version of the boot menu.

No Emrion, only recently got the machine, and put 13.0 on it.
 

sko

Aspiring Daemon

Reaction score: 404
Messages: 708

I really wonder why the boot menu on a server is important... You'll never see it anyways, except in very rare emergencies when it really doesn't matter if it has a fancy look. I also don't know how/if the graphical menu will work over a SOL (which I sometimes still prefer over the otherwise great Supermicro HTML5 console).

Usually you also don't want the host to use the graphics card for video output (I suspect it is installed for transcoding or pass through to a VM?) - the host should always use the aspeed chipset so the IPMI can redirect all output.
So the screen.textmode or any X related "workarounds" don't apply here. As far as the host is concerned, it doesn't need the Nvidia GPU at all for video output.
 
OP
Geezer

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

I also don't know how/if the graphical menu will work over a SOL (which I sometimes still prefer over the otherwise great Supermicro HTML5 console).

Usually you also don't want the host to use the graphics card for video output (I suspect it is installed for transcoding or pass through to a VM?) - the host should always use the aspeed chipset so the IPMI can redirect all output.
So the screen.textmode or any X related "workarounds" don't apply here. As far as the host is concerned, it doesn't need the Nvidia GPU at all for video output.

If it were purely a server, I would not need the nvidia. It is a workstation too.

I like the supermicro html5 kvm. I like supermicro ... generally. And it has a good working sol.

I really wonder why the boot menu on a server is important... You'll never see it anyways, except in very rare emergencies when it really doesn't matter ....

I am sure it does not matter to you. It must matter though, or else it would not have been put in, in the first place.
 
OP
Geezer

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

For those who are interested (which may be few), here is how it looks with the supermicro board and both the html5 kvm and the sol.

KVM:
kvm1.png

kvm2.png


kvm3.png

And that is as far as it gets, probably because I am using an off board graphics card.

And now the SOL:
sol1.png


sol2.png


... (continued) ...
 
OP
Geezer

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

sol3.png


Oh dear, boot menu a bit messed up.

But it does clear up when it starts booting and gets cleanly all the way to the login prompt.

I was using the xfce terminal, but if you think that was what messed it up, here it is from xterm:
sol.xterm.png


Anyway, it is still functional.

Back to the begining of the thread, I did try it all with the on board graphics card as well, and got the same boot menu. Does not do the shiny graphics.
 

sko

Aspiring Daemon

Reaction score: 404
Messages: 708

And that is as far as it gets, probably because I am using an off board graphics card.
Exactly, that's why you usually don't use the addon graphics card for video output on a normal server...

The messed up SOL on your later screenshots most likely comes from wrong encoding and/or bitrate. Check the settings in the BIOS and IPMI and set them accordingly when connecting with ipmiview. Usually the defaults are fine and 'just work'™
 
OP
Geezer

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

Exactly, that's why you usually don't use the addon graphics card for video output on a normal server...

The messed up SOL on your later screenshots most likely comes from wrong encoding and/or bitrate. Check the settings in the BIOS and IPMI and set them accordingly when connecting with ipmiview. Usually the defaults are fine and 'just work'™
It is not a normal server. It is a workstation too.

This is what I have got in loader.conf which corresponds with SOL at it is in the bios.
Code:
# SOL
boot_multicons="YES"
boot_serial="YES"
comconsole_speed="115200"
comconsole_port="0x2F8"
console="comconsole,efi"

It only messes up for the boot menu. Everything after that is usable.
 
Last edited by a moderator:
OP
Geezer

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

Looked in bios, data/parity/stop/flow 8/none/1/none

Terminal type VT100+ (dunno what the plus is ) out of VT100/VT100+/VT-UTF8/ANSI
 

joplass

Active Member

Reaction score: 46
Messages: 249

Sorry to be using this thread as a follow up. If my actions are offending anyone kindly let me know and I will start a new thread.

I am on a laptop with nvidia running. I use legacy BIOS. Is there any hope for me to have the new boot logo? I still have ascii on 13.0-RELEASE.
 

T-Daemon

Daemon

Reaction score: 884
Messages: 1,764

One of my machines is a workstation with BIOS and NVIDIA GPU. Setting following scales up the screen resolution and displays the graphics logo. I do care more about the resolution than the logo, though.

/boot/loader.conf
Code:
vbe_max_resolution="720p"
Instead of 720p choose a greater or custom resolution. See loader.conf(5)

If you want the fonts smaller see the screen.font setting. A selection of fonts that can be used with the setting are in /boot/fonts.
 

olli@

Daemon
Developer

Reaction score: 1,255
Messages: 1,140

I am on a laptop with nvidia running. I use legacy BIOS. Is there any hope for me to have the new boot logo? I still have ascii on 13.0-RELEASE.
Some Nvidia system – especially recent ones – do not contain a VBE anymore (VESA BIOS extension). On these systems, graphics mode is not supported by FreeBSD’s boot loader when booting in CSM mode (legacy BIOS).
As far as I know, for graphics mode supported by the boot loader, either of these two environments is required:
  • When booting via legacy BIOS / CSM, there must be a VBE (VESA BIOS extension) either in the main BIOS or in the graphics card’s BIOS.
  • When booting via UEFI / EFI, the firmware must support UGA (universal graphics adapter) or GOP (graphics output protocol). This is usually the case if the firmware setup supports high-res graphics mode, i.e. anything beyond standard VGA (800 × 600 pixels).
 

joplass

Active Member

Reaction score: 46
Messages: 249

One of my machines is a workstation with BIOS and NVIDIA GPU. Setting following scales up the screen resolution and displays the graphics logo. I do care more about the resolution than the logo, though.

/boot/loader.conf
Code:
vbe_max_resolution="720p"
Instead of 720p choose a greater or custom resolution. See loader.conf(5)

If you want the fonts smaller see the screen.font setting. A selection of fonts that can be used with the setting are in /boot/fonts.
That worked with fonts but the new shiny logo did not show up. I wonder if there is another steps.

Thank you for your help.
 

joplass

Active Member

Reaction score: 46
Messages: 249

oops. My celebration was short lived but from I have read this is most likely an nvidia driver issue. The screen just went pink and the box became unresponsive.
 

jmos

Well-Known Member

Reaction score: 192
Messages: 260

…and how do I get the cool, old ASCII art back? Already tried these lines in my /boot/loader.conf:
Code:
hw.vga.textmode="1"
screen.textmode="1"
bitmap_load="NO"
I'm always getting the new splash screen showing /boot/images/freebsd-logo-rev.png. Seems to be configured in /boot/lua/ directory… But I think that shouldn't be edited there, but in /boot/loader.conf; Even a loader_logo="beastie" doesn't bring back a full ASCII boot splash (just shows ASCII beastie beside graphic logo).
 
OP
Geezer

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

jmos No, no, no. How do I get the new flashy logos?

T-Daemon I did try vbe_max_resolution="720p". I also tried efi_max_resolution="720p". Made the text on the screen too big and so made the console unusable.

But I did have the KVM going, and the SOL. In fact two SOL sessions, one by sshing into the BMC and starting it from there, and the other using the Java SOL from the web-based IPMI.

All different.

HTML5 KVM (as before):
kvm.png


SOL using ssh (as before):
sol.ssh.png


Supermicro's own Java SOL:
sol.java.png
 
Top