boot hang FreeBSD 8.0-RELEASE

HMG

New Member


Messages: 8

When I try to boot, I get to:

Code:
        atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 irq 1 pnpid PNP0303 on isa0


and then nothing, no matter how long I wait. I would expect to see
this next:

Code:
        atkbd0: <AT Keyboard> irq 1 on atkbdc0


In January I installed FreeBSD 8.0-RELEASE. For 2 months, I was able
to shutdown and reboot many times as I gradually got it just the way I
want it,

16 Mar 2010 I switched over to using it as my main machine. Over the
next 2 weeks I did a heap of installs, mainly with pkg_add; but I also
did a couple of makes.

Today I decided to reboot to ensure that it still can - and it can't!

I've tried all the choices on the loader (?) menu including safe mode
and single user, all with the same result.

I've booted off 8.0-RELEASE-i386-livefs and mounted the root slice (?)
and edited fstab back to the original. I've performed an fsck on all
the relevant slices without problems.

Because it is hanging during the boot process, I cannot find logs that
might help me.


I'm tempted to work on rc.conf next, but I suspect that the problem
occurs earlier in the boot sequence. How do I confirm that? When it
hangs, I can do almost nothing with the keyboard. The best I have
achieved is to turn of the Num Lock light. There is no response to
Ctrl-Alt-Delete; I have to press Reset to reboot.

Can someone point me in a direction that will allow me to move forward
please.

I have stacks of other information, but I don't know what's relevant.

TIA.
 

z662

Well-Known Member

Reaction score: 3
Messages: 292

All the logs you are looking for are in /var/log. Have you modified /boot/loader.conf or your kernel as of late?
 
  • Thanks
Reactions: HMG

z662

Well-Known Member

Reaction score: 3
Messages: 292

Also, since it mentions your keyboard in the log, did you by chance change anything relating to HALD and DBUS in rc.conf or other places?
 
OP
HMG

HMG

New Member


Messages: 8

z662 said:
All the logs you are looking for are in /var/log. Have you modified /boot/loader.conf or your kernel as of late?

1. Thank you. The quoted response was correct.

2. I looked in /var/log. Not useful; there were no entries for the day I booted. In other words, the boot was failing before the system got to writing to /var/log.

3. As you correctly observed, /boot/loader.conf was the problem. I deleted it and copied an earlier version:

Code:
cp loader.conf.02 loader.conf


thereby restoring the situation to the state before 16 Mar 2010.

So thank you again. Your answer was perfect.

Can I impose on your patience and goodwill a little further, please?

I can't see what's wrong with my loader.conf (the one which doesn't work):

Code:
#       loader.conf - override file for /boot/defaults/loader.conf

# The dates refer to entries in /History

# 28 Jan 2010   USB keyboard

ukbd_load="YES"

# 19 Mar 2010   Firefox 3.5 and HTML5 (see /History)

# Certain functions used to display HTML5 elements need the sem module.

sem_load="YES"

# 20 Mar 2010   Setting Up the Sound Card

snd_ich_load="YES"      # Intel ICH5

 

osx-addict

Active Member

Reaction score: 3
Messages: 174

perhaps some issue with ukbd_load? Not sure what it does but since it gets stuck with the keyboard that sounds reasonable.. Does the original not have that line -- I'm assuming it does not. If your machine works w/o that line then I'd consider this solved and move on.. unless there's something you need related to the above line.. Just my $0.02 worth which aint much!
 
OP
HMG

HMG

New Member


Messages: 8

I knew I should have said a bit more. No, that seems to be the one line which is ok. Here's the entire loader.conf which works:

Code:
ukbd_load="YES"


I'm trying to avoid 4 or 5 reboots.
 

fronclynne

Daemon

Reaction score: 177
Messages: 1,296

Well, from here /usr/src/sys/amd64/conf/GENERIC has
Code:
options         P1003_1B_SEMAPHORES     # POSIX-style semaphores
(as does /usr/src/sys/i386/conf/GENERIC), so your sem_load line is redundant, at best (cf sem(4)).

ukbd(4) is also in GENERIC, so if you're running GENERIC, or your custom kernel still has it included, you might take it out of your /boot/loader.conf.

snd_ich(4) doesn't seem to hurt my old thinkpad any, so without any better information, that line seems safe.

Most kernel modules will fail to load (with a brief error) if the driver is already in your kernel, but be safe.
 
  • Thanks
Reactions: HMG
OP
HMG

HMG

New Member


Messages: 8

[Solved] boot hang FreeBSD 8.0-RELEASE Reply to Thread

1. Thanks, fronclynne. Yes I am running GENERIC:

Code:
FreeBSD freew.t-s-f.com.au 8.0-RELEASE FreeBSD 8.0-RELEASE #0: Sat Nov 21 15:48:17 UTC 2009     root@almeida.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  i386


It's a totally unmodified out-of-the-box standard install.

2. Re ukbd_load: these entries in /var/log/messages support your post:


Code:
Apr  2 06:20:45 freew kernel: module_register: module uhub/ukbd already exists!
Apr  2 06:20:45 freew kernel: Module uhub/ukbd failed to register: 17



2.1. It's already in my kernel (and therefore not needed in loader.conf).

2.2. It's redundant, but fails safely.

3. Re sem_load: I'm persuaded by your reasoning. I may never know,
because I don't know if I'll notice HTML5 elements - or their absence.

4. That leaves me with comments and the single functional line:

Code:
snd_ich_load="YES"


And, sure enough, that solves my problem! Thanks again.

5. How do I mark this thread as solved? Or does that require more
powerful magic than available to me?

6. For completeness, I tried to determine what causes my machine to
hang. After about 25 reboots, I can advise that:

6.1. The hang still occurs when loader.conf is reduced to:

Code:
ukbd_load="YES"
sem_load="YES"
snd_ich_load="YES"      # Intel ICH5

6.2. Each individual line by itself in loader.conf works!

6.3. Further, this does not hang:

Code:
ukbd_load="YES"
sem_load="YES"


6.4. I suspect a bug in the loader.
 

osx-addict

Active Member

Reaction score: 3
Messages: 174

HMG said:
5. How do I mark this thread as solved? Or does that require more
powerful magic than available to me?

Go and edit the original (1st) post and change "Prefix" to the left of the subject to be 'Solved'..
 
Top