blank screen after installing and enabling gnome3

I've just installed gnome3 and like a lot of first time users out there, I am also facing the issue of blank screen at bootup.

I had added gdm_enable to my /etc/rc.conf along with gnome_enable as had been advised in the handbook. Not to mention enabling dbus and hald as gnome depends on it. In short I went exactly by the rulebook but still :rolleyes:

Now I would like to capture the various logs to see what is going on, however I cannot switch to a virtual console from the blank screen. Without that it would be very difficult to ask for help here or anywhere else :(

I have tried alf+f1 to f8 but it is not responding. All I see is that blank screen. Apparently my keyboard itself seems to be not detected as numlock and scroll lock don't lit up when pressed.

I would like to add that when I had installed Xorg (which I did before installing gnome3), firing startx showed me that my keyboard and mouse had properly been detected (as I could see that classic three windows thing. So I assumed that gnome3 would also work flawlessly.

By the way I am using Optiplex 755 if that could help

Please advice.
 
Sure I would love to try all that however I cannot get the virtual console once the screen goes blank. I have tried the various Alt+F(1-8) key combination but nothing happens. I even tried booting in single user mode and wanted to disable automatic loading of GDM but I cannot save that file. It says SWAP isn't available which perhaps means the GEOM and subsequent upper layers of the storage stack are not initialized in that mode??

Nonetheless, as of now my main concern is to get to one of the virtual terminals. By the way I do have kern.vty=vt set in /boot/loader.conf.

Keen to hear
 

wblock@

Developer
By the way I do have kern.vty=vt set in /boot/loader.conf.
That was the point of that URL. A blank screen is usually caused by not enabling vt(4).

No idea which video card that particular machine has, please elaborate. If it is Intel or AMD, should be fine unless it is new. Don't know about Nvidia.
 
The problem is simple. Optiplex 755 has an embedded intel graphic card with a vga output (No DVI). I assume that you attached a monitor like a 23" and the screen resolution too high. Xorg cannot configure it properly and doesn't create the xorg.conf.new file. The result is a blank screen. The only way to fix it is to add a new video card (don't forget! It is an old PC) or change the resolution on your monitor.
 

wblock@

Developer
The blank screen is usually due to switching to graphics mode and then not switching back to console mode. Using vt(4) is usually a cure.

The suggested failure mode is unlikely. If a monitor has a physical resolution higher than the card can support, it will use a lower resolution that is supported.

Finally, please do not auto-generate Xorg config files any more. Let X auto-configure at run time.
 
Top