Black Screen after S3 suspending. Samsung Laptop



Hi everybody,
I got a 2nd-handed Samsung NP-R519 2-3 months ago, and since then I'haven't managed to suspend/resume correctly.
Unfortunately I didn't check whether or not suspending worked well at least on Windows, before wiping it out and installing FreeBSD (currently on 11.1-p4).

hw.model: Pentium(R) Dual-Core CPU       T4300  @ 2.10GHz
hw.machine: amd64
hw.ncpu: 2

Model Family:     SAMSUNG SpinPoint M7
Device Model:     SAMSUNG HM320II
Serial Number:    S20SJD0SA59230
LU WWN Device Id: 5 0024e9 0024c00f7
Firmware Version: 2AC101C4
User Capacity:    320,072,933,376 bytes [320 GB]
Sector Size:      512 bytes logical/physical
Form Factor:      2.5 inches
ATA Version is:   ATA8-ACS T13/1699-D revision 6
SATA Version is:  SATA 2.6, 3.0 Gb/s
Local Time is:    Mon Nov 20 13:49:55 2017 CET
SMART support is: Enabled

real memory  = 4294967296 (4096 MB)
avail memory = 4048891904 (3861 MB)

Model: Nvidia GeForce 105M
CUDA Cores: 16
VBIOS Version: 70.18.2b.00.ff
Total Memory: 512M
Bus Type: PCI Express x16 Gen1
On my previous laptop, I was used to setting ACPI S1 Suspend State for both Suspend Button and Lid Close.

However it seems this laptop doesn't support it:
hw.acpi.supported_sleep_state: S3 S4 S5
Even though:
hw.acpi.s4bios: 0
Now, according to acpi(4), if S4BIOS is not available S4 shouldn't either. However, if I set anything to S4 (let's say lid close), it works out of the box.

Nonetheless, since S4 is no use for me, I was hoping to set at least suspend button to S3.

If I try to do so, the system correctly stops running, LEDs indicate it's hibernated, and when I press the power button, it resumes in 4-5s, monitor's light is on, but the only thing I get is a black screen. I tried waiting, yet nothing changes, I'm just forced to hold down the power button and reboot.
This happens either when I try to suspend from Xorg, or tty.

I had acpi_video.ko loaded in order to adjust brightness, thought it could interfere, so I disabled it, but still with no luck.

Am I doing something wrong?How is S3 state suspend/resume supposed to behave (when it works well)?

Anyone running FreeBSD on a Samsung laptop?

Thanks in advance
S3 doesn't work super well, only S1 and S2 are supported 100%.

I can't remember where I get this from, I think it's from when I was looking for TurboBoost, and how to enable it/make sure it was working...

... yeah... that's it...

So no, just S1 and S2, S3 is kinda finicky and fiddly, didn't see any support for S4+.
Have you tried these settings in your /etc/sysctl.conf
Have you tried these settings in your /etc/sysctl.conf

Hi Phishfry, unfortunately I had tried already to set the hw.acpi.reset_video option to 1, but had no luck. With reset_video enabled, the monitor didn't wake up and light on either, like it did before instead (albeit showing only a black screen). It felt like having gone one step backward fron the solution, so I disabled it.

lid_switch and sleep_button_state are already set as well to S3 in /etc/sysctl.conf.

I looked up the BIOS in search of any suspend/resume option to enable, and the only thing I found is:

- "USB S3 wake up" (it says that enabling it would allow systems like Win 7 and later to wake up the PC from a S3 suspend state, through "USB activities")

There's also a "Large Disk Access Mode" entry, which is currently set to "DOS", but it says to set it to "Other" for "Unix/Novell Operating Systems"
Phishfry perhaps do you know if there's a dedicated power management driver, anything like acpi_ibm(4), acpi_toshiba(4) or acpi_panasonic(4) for Samsumg, to control suspend/resume?

I've managed to get volume up/down, brightness up/down, LCD backlight, zoom +/- , print and numlock buttons working on Fluxbox, but this suspend/resume thing seems to be unsolvable