Bitmap fonts fall back to scalable

Hey, I'm having this problem on 13.0-RELEASE where I can't select bitmap fonts in lxappearence. They simply don't appear in the menu. They appear in my wm's menu (windowmaker) but they just fall back to ttf fonts. They work fine in firefox and applications which use the old x11 toolkit such as urxvt. fc-match also shows no abnormalities and I have 70-yes-bitmaps.conf so I have no idea what's going on.

% fc-match ohsnap
OhsnapMedium-13.bdf: "Ohsnap" "Regular"
I don't think that's the problem, because I installed terminus-ttf and it worked. No bitmap fonts work, not even the ones that come stock with xorg.

Could this possibly be the problem? Can anyone running 13.0-RELEASE confirm if bitmap fonts work in gtk+ applications?
You said that it couldn't be. That link is literally the second line of the mailing list message I posted.
I tried installing x11-fonts/fifteen, and sure enough "Twelve" (FifteenNarrow-15.bdf) was missing from LXAppearance, so it's possible the issue is related to Pango dropping support for bitmap fonts:
$ fc-list | grep /fifteen/
/usr/local/share/fonts/fifteen/FifteenNarrow-15.bdf: Twelve:style=Bold
/usr/local/share/fonts/fifteen/FifteenNarrow.ttf: Fifteen:style=Regular
/usr/local/share/fonts/fifteen/QuinzeNarrow.ttf: Quinze:style=Regular

Incidentally, Firefox had no problem working with the "Twelve" font as long as the font size was 12, but I don't know what magic it's using to do so.


You may need to enable bitmap fonts on /usr/local/etc/fonts; however you are likely to end up with the "ugly fonts on Firefox" problem therefore you may be better enabling just what you need (search on the forums about it).
You said that it couldn't be. That link is literally the second line of the mailing list message I posted.
I'm sorry, I made a mistake. I had multiple tabs open and went through another issue thinking it was the one you linked.

It's such a good feeling to know that pango devs get together every few months to screw up text rendering for everyone. Like when their update made underlines stop being rendered for certain fonts. But hey, at least we have the uber important color emoji support, right?

Anyone got amd64 libpango v1.43 lying around to share? Maybe it still works. In the meantime, I'm trying to convert the fonts I use to otb, but the results are a mess, sadly.
Heh, I just realised the pango version in my ports tree is 1.42, so I installed it from there "temporarily", but will probably keep using it until something breaks (don't try this at home).

Captura de tela_2021-08-04_00-55-25.png
Is it fork o'clock?

I support that idea 100%. Someone should absolutely create and maintain pango-notbroken. I'll contribute zero work towards that.

Seriously though, that's the best path forward. I doubt that if bitmap font support was added to harfbuzz it would render the same. Also, just realized this broke thunar. But thunar has been in decay since moving to gtk3 anyway, so I just bit the bullet and moved to pcmanfm.