Big problem with Sendmail

godzilla

New Member


Messages: 9

#1
Hello from this morning, without touching NOTHING on a working sendmail freeBSD server we have this problem:

We can receive mail local and from the inet.
But we can't send !!!

The log shows the following :

Code:
Nov 21 13:43:12 mail sendmail[974]: mALAgvkr000974: to=isidoro,jlopez, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=153266, relay=local, dsn=2.0.0, stat=Sent
Nov 21 13:43:24 mail sendmail[2391]: mALB0cU1001273: to=<penelopehipotk@yahoo.es>, ctladdr=<fax2mail@invox.es> (1026/1026), delay=01:42:45, xdelay=00:12:47, mailer=esmtp, pri=250483, relay=e.mx.mail.yahoo.com. [216.39.53.1], dsn=4.0.0, stat=Deferred: Operation timed out with e.mx.mail.yahoo.com.
Nov 21 13:43:39 mail sendmail[1120]: mAL7wxxk066512: to=<mercedes@tarotmercedes.com>, ctladdr=<cmolini@numintel.es> (1023/1023), delay=04:44:39, xdelay=00:02:34, mailer=esmtp, pri=392467, relay=mailback.ackstorm.com. [62.97.115.10], dsn=4.0.0, stat=Deferred: Operation timed out with mailback.ackstorm.com.
Nov 21 13:43:54 mail sm-mta[1448]: mAL9NkEY067475: to=<rmedel@pedial.com>, ctladdr=<fax2mail@invox.es> (1026/1026), delay=03:20:08, xdelay=00:01:16, mailer=esmtp, pri=488763, relay=mail.pedial.com. [86.109.103.54], dsn=4.0.0, stat=Deferred: Operation timed out with mail.pedial.com.
Nov 21 13:43:54 mail sm-mta[1448]: mALAr8W9001130: to=<faxcolt@corporacionlegal.com>, ctladdr=<fax2mail@invox.es> (1026/1026), delay=01:50:46, xdelay=00:00:00, mailer=esmtp, pri=221071, relay=cleopatra-asplus.adam.es., dsn=4.0.0, stat=Deferred: Operation timed out with cleopatra-asplus.adam.es.
Nov 21 13:44:11 mail dovecot: imap-login: Login: user=<pedro>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Nov 21 13:44:11 mail dovecot: IMAP(pedro): Disconnected: Logged out
Nov 21 13:44:41 mail sendmail[2391]: mALB9xFj001466: to=<faxcolt@corporacionlegal.com>, ctladdr=<fax2mail@invox.es> (1026/1026), delay=01:34:41, xdelay=00:01:17, mailer=esmtp, pri=430684, relay=cleopatra-asplus.adam.es. [212.36.64.60], dsn=4.0.0, stat=Deferred: Operation timed out with cleopatra-asplus.adam.es.
Nov 21 13:44:41 mail sendmail[2391]: mALB7VBm001436: to=isidoro@mobileemail.vodafone.es  , ctladdr=<eescorihuela@invox.es> (1009/1009), delay=01:37:10, xdelay=00:00:00, mailer=esmtp, pri=340691, relay=vodaes.mx2.eu.blackberry.com., dsn=4.0.0, stat=Deferred: Operation timed out with vodaes.mx2.eu.blackberry.com.
Nov 21 13:44:41 mail sendmail[2391]: mALBTBoK001660: to=<faxcolt@corporacionlegal.com>, ctladdr=<fax2mail@invox.es> (1026/1026), delay=01:15:30, xdelay=00:00:00, mailer=esmtp, pri=432027, relay=cleopatra-asplus.adam.es., dsn=4.0.0, stat=Deferred: Operation timed out with cleopatra-asplus.adam.es.
Nov 21 13:44:41 mail sendmail[2391]: mALBqXJP002223: to=<faxcolt@corporacionlegal.com>, ctladdr=<fax2mail@invox.es> (1026/1026), delay=00:52:08, xdelay=00:00:00, mailer=esmtp, pri=342923, relay=cleopatra-asplus.adam.es., dsn=4.0.0, stat=Deferred: Operation timed out with cleopatra-asplus.adam.es.
We are not banned in the CBL black list.

What is happening ? Thanks !
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 2,656
Messages: 11,226

#2
Is mail coming in from the outside? Has your ISP decided to block port 25 traffic? Are you on a dynmiac/residential type of connection?

By the way: please edit or remove that piece of logfile. You're opening these addresses up to spam harvesting.
 
OP
OP
G

godzilla

New Member


Messages: 9

#3
No, It is mail being sent. There's a problem of connection timeout with the domain names of the mail relay. Connections are being made but then timeout !

Code:
192.168.0.44.65184     82.194.66.202.25       SYN_SENT
192.168.0.44.53605     209.85.218.178.25      SYN_SENT
192.168.0.44.60799     213.192.205.35.25      SYN_SENT
192.168.0.44.52206     209.85.218.179.25      SYN_SENT
192.168.0.44.58646     65.54.245.104.25       SYN_SENT
192.168.0.44.64638     216.9.253.32.25        SYN_SENT
192.168.0.44.55056     217.116.0.152.25       SYN_SENT
192.168.0.44.25        119.42.77.113.25499    TIME_WAIT
192.168.0.44.50418     216.9.253.32.25        SYN_SENT
192.168.0.44.50549     209.85.218.176.25      SYN_SENT
192.168.0.44.52106     217.116.0.162.25       SYN_SENT
192.168.0.44.25        213.192.208.226.12993  ESTABLISHED
192.168.0.44.22        192.168.0.90.38250     ESTABLISHED
*.25                   *.*                    LISTEN
*.25                   *.*                    LISTEN
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 2,656
Messages: 11,226

#4
It doesn't look like a Sendmail problem to me, just a network/filtering problem. I'd suggest contacting your ISP or upstream connectivity provider, or using their mail relay host if they have one.
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 2,656
Messages: 11,226

#6
Can you perform a simple 'telnet someserver 25' to some of the servers mentioned in your maillog? Just to see if they're actually reachable from your mailserver.
 
OP
OP
G

godzilla

New Member


Messages: 9

#7
Done DutchD ! We changed the GW to another router attached to another ISP connection and the queue is being sent. Probably a crappy tech has gone wild on the other side.

Thank you a lot.
 
OP
OP
G

godzilla

New Member


Messages: 9

#8
How do you set up the mail relay of the provider ? We use webmin to control and configure Sendmail . . . is there a way through the web interface to configure it ?

Thanks dutch !
 

brd@

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 85
Messages: 292

#9
Look for a setting called "Smart Host".
 
Top