Beagle Bone Black/Green

comarius

New Member


Messages: 5

#1
Hi,
I am struggling for a day now to boot 'https://wiki.freebsd.org/FreeBSD/arm/BeagleBoneBlack' on either BeagleBone Green or Black.
I have a bunch of class 10 SD cards. I burn all 2018 may versions. The system picks the eMMC uboot and reboot's forerev in u-boot prompt.

Then I followed the procedure holding the user button (the one close to the sdcard side) down, powering, holding more 3 seconds, even 5, even 7
but noting happen. I can see only on my console CCCCCCCC going forever.

Also tried:

Code:
=> print loadaddr
loadaddr=0x82000000

=>  fatload mmc 0:1 82000000 ubldr.bin
reading ubldr.bin
Invalid FAT entry
8192 bytes read in 8 ms (1000 KiB/s)
=>  fatload mmc 0:1 0x82000000 ubldr.bin
reading ubldr.bin
Invalid FAT entry
8192 bytes read in 7 ms (1.1 MiB/s)
=>


I am wondering what I am doing wrong.
he BBB and BBG boots fine the original eMMC debian, and any other sdcard with linux.
Thank you.
 
OP
OP
C

comarius

New Member


Messages: 5

#2
SOLVED

Looks like all 2018 images are bad.
FreeBSD-12.0-CURRENT-arm-armv7-BEAGLEBONE-2018MMDD-r######.img
I used
FreeBSD-armv6-12.0-BEAGLEBONE-307333M.img
and looks OK, I passed the u-boot and boots fine. I have the login screen.
 

madaari

New Member

Thanks: 7
Messages: 10

#3
Hi,
I am struggling for a day now to boot 'https://wiki.freebsd.org/FreeBSD/arm/BeagleBoneBlack' on either BeagleBone Green or Black.
I have a bunch of class 10 SD cards. I burn all 2018 may versions. The system picks the eMMC uboot and reboot's forerev in u-boot prompt.

Then I followed the procedure holding the user button (the one close to the sdcard side) down, powering, holding more 3 seconds, even 5, even 7
but noting happen. I can see only on my console CCCCCCCC going forever.


Also tried:

Code:
=> print loadaddr
loadaddr=0x82000000

=>  fatload mmc 0:1 82000000 ubldr.bin
reading ubldr.bin
Invalid FAT entry
8192 bytes read in 8 ms (1000 KiB/s)
=>  fatload mmc 0:1 0x82000000 ubldr.bin
reading ubldr.bin
Invalid FAT entry
8192 bytes read in 7 ms (1.1 MiB/s)
=>


I am wondering what I am doing wrong.
he BBB and BBG boots fine the original eMMC debian, and any other sdcard with linux.
Thank you.
True. I also had this issue. It looks like there's some issue in the recent uboot build, otherwise kernel alone is working fine
 
Top