bce0 : /usr/src/sys/dev/bce/if_bce.c(1044): No PHY found on Child MII bus

celica013

New Member


Messages: 7

I'm try to install FreeBSD 7-RC2 on IBM Blade HS21 on Chassis H using MSIM ( Multi Switch Interconnect Module ). There were 4 ethernet module[ broadcomm netextreme ]. The name are bce0 through bce3. On "dmesg" view I could see bce0 through bce3 were detected, but on "sysinstall" I can't see bce0 and bce1 so I can't configure IP address for bce0 and bce1.

Ever someone connecting IBM DS3400 with HS21 server use FreeBSD more than one server HS21 with different LUN ?

On "dmesg" message found error : "bce0 : /usr/src/sys/dev/bce/if_bce.c(1044): No PHY found on Child MII bus".

Why this happen ? Can any body help me to solve this problem ?

Regards,

Ivan.S
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,818
Messages: 11,305

Are you running a GENERIC kernel? Do these interfaces show up under [cmd=]ifconfig -a[/cmd]?

On a side note: could this be another bce problem, on top of the one with lagg?
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,818
Messages: 11,305

Code:
         /* Check for an MII child bus by probing the PHY. */
         if (mii_phy_probe(dev, &sc->bce_miibus, bce_ifmedia_upd,
                 bce_ifmedia_sts)) {
                 BCE_PRINTF("%s(%d): No PHY found on child MII bus!\n", 
                         __FILE__, __LINE__);
                 rc = ENXIO;
                 goto bce_attach_fail;
I was thinking that maybe you had a custom kernel with a missing 'device miibus' (which 'device bce' needs), but that would mean you would not be able to load any bce device, whereas you have a 50% hit rate ..

Could you post the whole dmesg portion dealing with detecting and setting up the network cards? I'm curious as to what was reported for the interfaces that succeeded.
 
OP
OP
C

celica013

New Member


Messages: 7

dmesg -a output

Code:
Copyright (c) 1992-2009 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.2-RELEASE #0: Fri May  1 07:18:07 UTC 2009
    [email]root@driscoll.cse.buffalo.edu[/email]:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Xeon(R) CPU           E5450  @ 3.00GHz (3000.12-MHz K8-class CPU)
  Origin = "GenuineIntel"  Id = 0x1067a  Stepping = 10
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0x40ce3bd<SSE3,RSVD2,MON,DS_CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,DCA,<b19>,XSAVE>
  AMD Features=0x20000800<SYSCALL,LM>
  AMD Features2=0x1<LAHF>
  Cores per package: 4
usable memory = 8575840256 (8178 MB)
avail memory  = 8266412032 (7883 MB)
ACPI APIC Table: <IBM    SERBLADE>
FreeBSD/SMP: Multiprocessor System Detected: 8 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
 cpu2 (AP): APIC ID:  2
 cpu3 (AP): APIC ID:  3
 cpu4 (AP): APIC ID:  4
 cpu5 (AP): APIC ID:  5
 cpu6 (AP): APIC ID:  6
 cpu7 (AP): APIC ID:  7
ioapic1 <Version 2.0> irqs 24-47 on motherboard
ioapic0 <Version 2.0> irqs 0-23 on motherboard
registered firmware set <isp_1040>
registered firmware set <isp_1040_it>
registered firmware set <isp_1080>
registered firmware set <isp_1080_it>
registered firmware set <isp_12160>
registered firmware set <isp_12160_it>
registered firmware set <isp_2100>
registered firmware set <isp_2200>
registered firmware set <isp_2300>
registered firmware set <isp_2322>
registered firmware set <isp_2400>
kbd1 at kbdmux0
acpi0: <IBM SERBLADE> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x588-0x58b on acpi0
pcib0: <ACPI Host-PCI bridge> on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 2.0 on pci0
pci7: <ACPI PCI bus> on pcib1
pcib2: <ACPI PCI-PCI bridge> at device 0.0 on pci7
pci9: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 0.0 on pci9
pci11: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> at device 1.0 on pci9
pci10: <ACPI PCI bus> on pcib4
pcib5: <ACPI PCI-PCI bridge> at device 0.3 on pci7
pci8: <ACPI PCI bus> on pcib5
isp0: <Qlogic ISP 2422 PCI FC-AL Adapter> port 0x5000-0x50ff mem 0xd6fff000-0xd6ffffff irq 25 at device 1.0 on pci8
isp0: [ITHREAD]
isp0: Board Type 2422, Chip Revision 0x2, loaded F/W Revision 4.0.20
isp1: <Qlogic ISP 2422 PCI FC-AL Adapter> port 0x5100-0x51ff mem 0xd6ffe000-0xd6ffefff irq 26 at device 1.1 on pci8
isp1: [ITHREAD]
isp1: Board Type 2422, Chip Revision 0x2, loaded F/W Revision 4.0.20
pcib6: <ACPI PCI-PCI bridge> at device 3.0 on pci0
pci15: <ACPI PCI bus> on pcib6
pcib7: <ACPI PCI-PCI bridge> at device 4.0 on pci0
pci12: <ACPI PCI bus> on pcib7
bce0: <Broadcom NetXtreme II BCM5709 1000Base-SX (C0)> mem 0xd2000000-0xd3ffffff irq 17 at device 0.0 on pci12
bce0: /usr/src/sys/dev/bce/if_bce.c(1044): No PHY found on child MII bus!
device_attach: bce0 attach returned 6
bce1: <Broadcom NetXtreme II BCM5709 1000Base-SX (C0)> mem 0xd0000000-0xd1ffffff irq 18 at device 0.1 on pci12
bce1: /usr/src/sys/dev/bce/if_bce.c(1044): No PHY found on child MII bus!
device_attach: bce1 attach returned 6
pcib8: <ACPI PCI-PCI bridge> at device 5.0 on pci0
pci14: <ACPI PCI bus> on pcib8
bce2: <Broadcom NetXtreme II BCM5709 1000Base-SX (C0)> mem 0xce000000-0xcfffffff irq 18 at device 0.0 on pci14
bce2: /usr/src/sys/dev/bce/if_bce.c(1044): No PHY found on child MII bus!
device_attach: bce2 attach returned 6
bce3: <Broadcom NetXtreme II BCM5709 1000Base-SX (C0)> mem 0xcc000000-0xcdffffff irq 19 at device 0.1 on pci14
bce3: /usr/src/sys/dev/bce/if_bce.c(1044): No PHY found on child MII bus!
device_attach: bce3 attach returned 6
pcib9: <ACPI PCI-PCI bridge> at device 6.0 on pci0
pci3: <ACPI PCI bus> on pcib9
pcib10: <PCI-PCI bridge> at device 0.0 on pci3
pci4: <PCI bus> on pcib10
bce4: <Broadcom NetXtreme II BCM5708 1000Base-SX (B2)> mem 0xda000000-0xdbffffff irq 17 at device 0.0 on pci4
miibus0: <MII bus> on bce4
brgphy0: <BCM5708S 1000/2500BaseSX PHY> PHY 2 on miibus0
brgphy0:  1000baseSX-FDX, auto
bce4: Ethernet address: 00:21:5e:63:c9:ba
bce4: [ITHREAD]
bce4: ASIC (0x57081021); Rev (B2); Bus (PCI-X, 64-bit, 133MHz); B/C (0x04040105); Flags( MFW MSI )
pcib11: <ACPI PCI-PCI bridge> at device 7.0 on pci0
pci5: <ACPI PCI bus> on pcib11
pcib12: <PCI-PCI bridge> at device 0.0 on pci5
pci6: <PCI bus> on pcib12
bce5: <Broadcom NetXtreme II BCM5708 1000Base-SX (B2)> mem 0xd8000000-0xd9ffffff irq 19 at device 0.0 on pci6
miibus1: <MII bus> on bce5
brgphy1: <BCM5708S 1000/2500BaseSX PHY> PHY 2 on miibus1
brgphy1:  1000baseSX-FDX, auto
bce5: Ethernet address: 00:21:5e:63:c9:bc
bce5: [ITHREAD]
bce5: ASIC (0x57081021); Rev (B2); Bus (PCI-X, 64-bit, 133MHz); B/C (0x04040105); Flags( MSI )
pci0: <base peripheral> at device 8.0 (no driver attached)
pcib13: <ACPI PCI-PCI bridge> at device 28.0 on pci0
pci2: <ACPI PCI bus> on pcib13
That's for dmesg -a output [ threads : #496260 ]...Thx ! And already paste it to http://pastie.org

Rgds,

Celica013
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,818
Messages: 11,305

So that blade has four Broadcom NetXtreme II BCM5709 NICs that won't work (bce0 - bce3), and two additional Broadcom NetXtreme II BCM5708 NICs that appear to be working fine (bce4 and bce5)? Do these two show up in ifconfig -a?

Anyway, there seems to be some movement on this subject:
http://www.freebsd.org/cgi/query-pr.cgi?pr=134658
 
Top