general/other Azure add user fail

tonyhain

Member

Reaction score: 4
Messages: 28

I am running a recently built (Mar. 11, '21) 12.2 as an Azure VM. I tried to enable the serial port, but that requires adding a passwd-auth user via the Azure portal. When I tried adding that the process hung in a loop for about an hour before timing out. Looking at the logs, WALinuxAgent is stuck, but I can't figure out why. The MSFT documentation claims that all Linux VMs come with the serial port enabled. Since the FreeBSD Marketplace distro runs in a Linux-type VM (ie: non-windows), there must be something in the Marketplace distro setup that is not providing a complete environment.

Looking at WALinuxAgent (waagent -v), the distribution appears to be shipping with a seriously dated version. The version included in the MarketPlace 12.2 distro is 2.2.45 (Nov. 19), while the current release of WALinuxAgent is 2.2.54.2 (Jan. 21). There was a bug fix for a looping WALinuxAgent in Jan '20 (shortly after the version included in the Marketplace distro). I tried manually installing that, but it is distributed with Linux path assumptions, and I haven't been able to find documentation that describes the changes needed to make those scripts work correctly with FreeBSD.

Any hints about enabling the serial port and/or updating the WALinuxAgent are appreciated.
Tony
 
Top