Awesome WM: keyboard layout issues

Hello everybody,

I'm having some problems with my French keyboard layout. Everything works fine when in console mode but as soon as I switch to X mode with awesome, the problems come.

I've been able to use, in console mode, my French keyboard without any problem (with éàè and #{[|`@ well every key works perfectly.
Here are my modifications:

in /etc/login.conf
Code:
#French Users
french:\
:charset=UTF-8:\
:lang=fr_FR.UTF-8:\
:tc=default:

then I do a # cap_mkdb /etc/login.conf

Then in ~/.login_conf
Code:
me:\
:charset=UTF-8:\
:lang=fr_FR.UTF-8:

So for the X mode:
I used the option of ignoring HAL (is it better to use it?). So as said in the manual, in Xorg.conf I did those modifications:
Code:
Section "ServerFlags"
	Option "AllowEmptyInput" "off"
	Option "AutoAddDevices" "off"
	Option "AutoEnableDevices" "off"
EndSection
Then:
Code:
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbLayout" "fr"
        Option      "XkbModel"  "pc102" (i'm not sure if it is a 105 or 102 or another thing. I have a laptop G50V for info)
EndSection

Then I start X with awesome WM.

I have Xterm and URXVT:
XTERM works fine with all keys that don't require ALT GR. When I try to enter keys like ~#{[|`\^@]} (using ALTGR) it starts showing me some "keys with accent" instead of those one.
URXVT: when trying to use the combination ALTGR+"anything" it starts beeping.

I tried another thing: when doing Mod4(windows key)+r to start a programm. Instead of typing firefox3 (for ex) I tried the ALTGR+"anything" to see if it worked. And it did. I was able to type a {[|@#^`{.

Does somebody know what i'm missing?

Thank you very much

PS: Same in Firefox3, I'm not able to use the ALTGR+"anything" combination.
 
Thank you, i just tried but still the same problem.

Everything works fine except the combination ALTGR+"any key".
 
I recently had a similar problem: I use the Dvorak layout (an uncommon US keyboard layout), and wanted to enable AltGr for typing special characters. Unfortunately, it seems that AltGr is tightly coupled to a keyboard layout, because it is treated like a variant of the Shift key. As a result, it cannot be easily added to a layout that doesn’t have it.
Juh924 said:
XTERM works fine with all keys that don't require ALT GR. When I try to enter keys like ~#{[|`\^@]} (using ALTGR) it starts showing me some "keys with accent" instead of those one.
I think I know this problem—to confirm it, hold AltGr when you type “asdf”. It will give you “áïâõ” (bad!). This is because when Alt is treated like Meta instead of AltGr, xterm sets the high bit of the ASCII character. In a layout with working AltGr, this will not happen. For instance, if you try the US international layout:

$ setxkbmap -layout us -variant intl

Holding AltGr and pressing “asdf” should give the correct (for US intl layout) “áßðf”.

Now, unless you’re planning on switching to US‐intl, the above doesn’t solve your problem. Sorry! I would fix it if I knew how, but all my attempts to gain understanding by diving into the Xkb configuration have failed.

So what can you do instead? Well, there is an alternative: the Compose key. Sun keyboards from way back when had them, and you can map it to Right Alt like this:

$ setxkbmap -option compose:ralt

In my en_US.UTF-8 locale, I can now type AltGr ' e (in sequence, not at the same time) and get é. The default compose mappings are found in /usr/X11R6/share/X11/locale/$LC_CTYPE/Compose on my OpenBSD installation, and probably a similar place in FreeBSD. You can read about the format of the file in Compose(5) and in a topic I posted at Daemonforums.
 
Thank you very much.

I finally solved my problem doing a clean install and using HAL from the beginning. However, I now have the same error as the one I had on OpenBSD:

The XKEYBOARD keymap compiler (xkbcomp) reports:
Code:
Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
                  Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server

It seems there is no solution found yet. But as long as the keyboard layout is working, this error could be ignored.
 
Top