Avocent DSRIQ-USB keyboard doesn't work with FreeBSD 11.2, does work with ⩽ 9

gessel

Active Member

Reaction score: 18
Messages: 116

I use an Avocent Autoview 3100 with DSRIQ-USB modules to manage my server. The most important phase is during BIOS, obvs, but it is a nice backup to have remote access to console should something unfortunate happen to ssh.

I've been using this config for ~10 years and have only occasionally had reason to make use of post-BIOS keyboard access. Recently I noticed it doesn't work. I have 3 physical machines connected. The keyboard works normally in BIOS, but stops working in console (I do not run X) as below:
  • Machine 1: FreeBSD 11.2-RELEASE-p10: does not work in console.
  • Machine 2: FreeBSD 11.2-RELEASE-p6: does not work in console
  • Machine 3: FreeBSD 9.2-RELEASE-p12: DOES work in console.
Machine 1 and 2 both worked fine at some time in the past. Alas, I'm not sure if support failed at 10.x or 11.x, but they're at 11.2 now and they definitely all worked fine at 9.x, as machine 3 does now.

It does seem to OS recognizes the device exists (machine 2 shown):

Bash:
dmesg.yesterday:ugen1.2: <Avocent Avocent DSRIQ-USB> at usbus1
It seems support is enabled:

Bash:
# ls /dev/kb*
/dev/kbd0       /dev/kbd1       /dev/kbd2       /dev/kbd3       /dev/kbdmux0
It seems odd that it worked out without any special config for many versions, but hasn't for a while. Reading https://docs.freebsd.org/doc/4.11-RELEASE/usr/share/doc/faq/compatibility-kbd-mice.html, it appears that the /etc/rc.conf or /etc/rc.i386 modifications are for X support. Are they needed for console support?

Thanks!
-David
 
Top