Xfce Audio not working on FreeBSD 10.2 x64 + XFCE

Hi to all!

I am new to FreeBSD, and I have followed this guide (http://www.freebsdworld.gr/files/install10-us.pdf) to install and configure the system.

I need to use the portuguese-brazilian (pt-br) keyboard layout, when I started the installation, a screen appeared asking what layout I wish to use, I've selected my layout (pt-br), but when I press the keys to test, some characters are not appearing as should be, maybe it's a bug from 10.2 version... after installing XFCE and SLIM login manager, I've logged into the system and noticed that there was no audio control panel... so I've installed the following packages:

$ sudo pkg install xfce4-volumed-pulse-0.2.0_1
$ sudo pkg install xfce4-pulseaudio-plugin-0.2.3


After that, I've rebooted, logged into system again and noticed that volume keys started to work and the 'Pulse Audio Volume Control' has appeared in 'Menu Applications > Multimedia', but when I start it, I cannot change my audio devices and when I execute a audio file or watch a video on YouTube, iI simply have no audio! I have the HDMI VGA audio card and the on-board audio, I wannawant to use PulseAudio to switch between them.

I also noticed after installing XFCE, I cannot change the consoles (Crtl + Alt +F1 ... F6 (tty0, tty1 ...), when I switch to another, my screen simply freezes with XFCE session opened, how can I fix that?
 
Just for update reasons... I have installed x11/gnome3 and x11/gdm, no problem until here. I've read the section "7.2. Setting Up the Sound Card" in FreeBSD Handbook and the book instructs to add a line snd_hda_load="YES" to /boot/loader.conf.

I will post my files, dmesg | grep pcm and cat /dev/sndstat outputs:

/boot/loader.conf:
Code:
sem_load="YES"
snd_driver_load="YES"

Code:
$ dmesg | grep pcm
pcm0: <ATI R6xx (HDMI)> at nid 3 on hdaa0
pcm1: <Realtek ALC888 (Rear Analog 7.1/2.0)> at nid 20,22,21,23 and 24,26 on hdaa1
pcm2: <Realtek ALC888 (Front Analog)> at nid 27 and 25 on hdaa1
pcm3: <Realtek ALC888 (Rear Digital)> at nid 30 and 31 on hdaa1

Code:
$ cat /dev/sndstat
Installed devices:
pcm0: <ATI R6xx (HDMI)> (play) default
pcm1: <Realtek ALC888 (Rear Analog 7.1/2.0)> (play/rec)
pcm2: <Realtek ALC888 (Front Analog)> (play/rec)
pcm3: <Realtek ALC888 (Rear Digital)> (play/rec)

/etc/sysctl.conf:
Code:
# $FreeBSD: releng/10.2/etc/sysctl.conf 112200 2003-03-13 18:43:50Z mux $
#
#  This file is read when going to multi-user and its contents piped thru
#  ``sysctl'' to adjust kernel values.  ``man 5 sysctl.conf'' for details.
#

# Uncomment this to prevent users from seeing information about processes that
# are being run under another UID.
#security.bsd.see_other_uids=0
hw.snd.default_unit=0
dev.pcm.0.play.vchans=4
dev.pcm.0.rec.vchans=4
hw.snd.maxautovchans=4

/boot/device.hints:
Code:
# $FreeBSD: releng/10.2/sys/amd64/conf/GENERIC.hints 276986 2015-01-11 17:10:07$
hint.fdc.0.at="isa"
hint.fdc.0.port="0x3F0"
hint.fdc.0.irq="6"
hint.fdc.0.drq="2"
hint.fd.0.at="fdc0"
hint.fd.0.drive="0"
hint.fd.1.at="fdc0"
hint.fd.1.drive="1"
hint.atkbdc.0.at="isa"
hint.atkbdc.0.port="0x060"
hint.atkbd.0.at="atkbdc"
hint.atkbd.0.irq="1"
hint.psm.0.at="atkbdc"
hint.psm.0.irq="12"
hint.sc.0.at="isa"
hint.sc.0.flags="0x100"
hint.uart.0.at="isa"
hint.uart.0.port="0x3F8"
hint.uart.0.flags="0x10"
hint.uart.0.irq="4"
hint.uart.1.at="isa"
hint.uart.1.port="0x2F8"
hint.uart.1.irq="3"
hint.ppc.0.at="isa"
hint.ppc.0.irq="7"
hint.atrtc.0.at="isa"
hint.atrtc.0.port="0x70"
hint.atrtc.0.irq="8"
hint.attimer.0.at="isa"
hint.attimer.0.port="0x40"
hint.attimer.0.irq="0"
hint.wbwd.0.at="isa"
hint.acpi_throttle.0.disabled="1"
hint.p4tcc.0.disabled="1"
hint.pcm.0.vol="50"

I still have no sound when I play a video on YouTube.
 
The online handbook needs to be updated. In FreeBSD 10.* and 11.* snd_hda(4) is statically compiled into the default kernel. Loading the module a second time in /boot/loader.conf is redundant.

Your system generates 4 different sound devices, pcm0 -> pcm3.
$ dmesg | grep pcm

pcm0: <ATI R6xx (HDMI)> at nid 3 on hdaa0
pcm1: <Realtek ALC888 (Rear Analog 7.1/2.0)> at nid 20,22,21,23 and 24,26 on hdaa1
pcm2: <Realtek ALC888 (Front Analog)> at nid 27 and 25 on hdaa1
pcm3: <Realtek ALC888 (Rear Digital)> at nid 30 and 31 on hdaa1

Using pcm0, your sound is output via the HDMI interface. If your speakers are plugged into the rear, typically green jack, you will need to set pcm1 as your default sound output (hw.snd.default_unit=1). If you are plugging in headphones in the "Front Analog" jack, then pcm2.
 
The Analogic Audio is working (Realtek ALC888), I will test the AMD HDMI, I've researched o web and some users say that AMD HDMI are not supported, is it true? ! I've replaced the module driver (snd_driver_load="YES") to (snd_hda_load="YES") in /boot/loader.conf . Will I have to set manually the audio devices? Because sometimes I like to hear through HDMI and other through a headphone, I have installed Pulse Audio, but if I change the devices, there is no difference!

I've thought the FreeBSD Handbook was already updated, because it says: Copyright © 1995-2015 The FreeBSD Documentation Project
 
Just the Realtek ALC888 works, the ATI R6xx (HDMI) isn't working...

PulseAudio doesn't make any difference, because when I enter on the control pane and switch between the audio devices, simply do nothing!
 
I've replaced the module driver (snd_driver_load="YES") to (snd_hda_load="YES") in /boot/loader.conf

You do not need the
Code:
snd_hda_load="YES"
in /boot/loader.conf. Remove it, reboot and you should find that Analog Sound still works. What has essentially been done, since snd_hda is now widely used, is that the hda sound driver has been statically compiled into the generic kernel. The process is described in section 7.2.1 of the handbook.


I do not use HDMI but I recall some posts where that was utilized.
This poster managed to get Thread 50950 working. It is the last post in the thread
 
Top