Solved audacity failed to build/upgrade because of dependencies

Minbari

Well-Known Member

Reaction score: 169
Messages: 322

I am trying to upgrade audio/audacity but I'm receiving the following error:


Code:
pkg-static: Unable to access file /usr/ports/x11-toolkits/wxgtk31/work/stage/usr/local/lib/wx/3.1.2/web-extensions/webkit2_extu-3.1.2.so:No such file or directory
*** Error code 74
because audacity require x11-toolkits/wxgtk31 as a dependency. x11-toolkits/wxgtk31 fails to build if I don't enable www/webkit2-gtk3.
So my question is: why do I have to install a web rendering engine to use an audio editor?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,087
Messages: 29,244

It's often used for help pages or online documentation.
 

garry

Member

Reaction score: 30
Messages: 44

I know that, but I don't get it why do I am forced to install it on my system.
Forced?!

You seem to building from ports, from source. You gave us a link to the freshports page for wxgtk31, which says that it has the following options:
Code:
Configuration Options ===> The following configuration options are available for wx31-gtk3-3.1.2_1:
     GSTREAMER=on: Multimedia support via GStreamer
     MSPACK=on: Microsoft archives support
     NLS=on: Native Language Support
     WEBKIT=on: WebKit webpage renderer support
===> Use 'make config' to modify these settings
so it would seem to be easy to avoid the webengine if you choose:
Code:
cd /usr/ports/x11-toolkits/wxgtk31
make config # turn the WEBKIT option off
... now build wxgtk31 and audacity without webkit.
 

tedbell

Member

Reaction score: 39
Messages: 99

I am having trouble building this from ports too. Actually it build fine but doesn't execute due to this error:

Code:
(Audacity:58841): Gtk-ERROR **: 03:02:55.657: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
[1]    58841 trace trap  audacity
 
OP
OP
Minbari

Minbari

Well-Known Member

Reaction score: 169
Messages: 322

Forced?!

You seem to building from ports, from source. You gave us a link to the freshports page for wxgtk31, which says that it has the following options:
Code:
Configuration Options ===> The following configuration options are available for wx31-gtk3-3.1.2_1:
     GSTREAMER=on: Multimedia support via GStreamer
     MSPACK=on: Microsoft archives support
     NLS=on: Native Language Support
     WEBKIT=on: WebKit webpage renderer support
===> Use 'make config' to modify these settings
so it would seem to be easy to avoid the webengine if you choose:
Code:
cd /usr/ports/x11-toolkits/wxgtk31
make config # turn the WEBKIT option off
... now build wxgtk31 and audacity without webkit.
I know how to install software from ports. My problem was exactly this one: turning off www/webkit2-gtk3 fails to build/upgrade the port. So yeah I'm forced to install it, which is kinda mind blowing.
 

garry

Member

Reaction score: 30
Messages: 44

Submit a PR for this.
I can confirm this problem. I set WEBKIT off for wxgtk31 and tried to build it in a chroot (synth build x11-toolkits/wxgtk31). The build of wxgtk31 fails in the packaging phase, perhaps the packing list needs correction. I'll wait for the OP to open a problem report and will append my log file for the failing wxgtk31 build.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,087
Messages: 29,244

Yeah, it happens. Ports can have issues. Especially with non-default options (de)selected as those are typically not tested by the automated build system (packages are always built using the port's default settings).
 

rhsbsd

Member

Reaction score: 12
Messages: 63

I am having trouble building this from ports too. Actually it build fine but doesn't execute due to this error:

Code:
(Audacity:58841): Gtk-ERROR **: 03:02:55.657: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
[1]    58841 trace trap  audacity
See this link. Lines 33, 35 are why. Seems as if, "I love this wording" webkit-gtk2-2.4.11_19 is de-orbiting. That's great except for this:
Code:
# pkg delete gtk2-2.24.32
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 35 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
        gtk2-2.24.32
        gconf2-3.2.6_5
        gtkmm24-2.24.5_1
        gtkspell-2.0.16_6
        libglade2-2.6.4_9
        py27-gtk2-2.24.0_5
        gnome-vfs-2.24.4_10
        libcanberra-0.30_4
        policykit-gnome-0.9.2_8
        libgnome-2.32.1
        libgnomecanvas-2.30.3_4
        gnome-mount-0.8_13
        libbonoboui-2.24.5_1
        libgnomeui-2.24.5
        py27-gnome-2.28.1_8
        gourmet-0.17.4_5
        avahi-gtk-0.7_1
        webkit-gtk2-2.4.11_19
        py27-poppler-0.12.1_12
        xscreensaver-5.42
        palemoon-27.9.4_4
        libreoffice-6.0.7_6
        inkscape-0.92.3_8
        webkit2-gtk3-2.22.6
        plasma5-kde-gtk-config-5.15.2
        wx30-gtk3-3.0.4_6
        firefox-esr-60.5.2_1,1
        driconf-0.9.1_12
        gvfs-1.30.4
        avahi-0.7
        gnome-online-accounts-3.28.0_1
        plasma5-plasma-5.15.2
        audacity-2.3.0_4
        libgdata-0.17.9
        kde5-5.15.2.18.12.2

Number of packages to be removed: 35
The operation will free 1 GiB.
Proceed with deinstalling packages? [y/N]: n
I used pkg delete -f gtk2-2.24.32 to just delete gtk. Audacity started and ran correctly but most everything else on the list failed. Do we have to ween our user-land of dated dependencies ourselves, or, is this a bigger problem? What I mean is if I delete all these including gtk2 will they all auto-magically switch to gtk3 when I rebuild?
 

tedbell

Member

Reaction score: 39
Messages: 99

See this link. Lines 33, 35 are why. Seems as if, "I love this wording" webkit-gtk2-2.4.11_19 is de-orbiting. That's great except for this:
Code:
# pkg delete gtk2-2.24.32
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 35 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
        gtk2-2.24.32
        gconf2-3.2.6_5
        gtkmm24-2.24.5_1
        gtkspell-2.0.16_6
        libglade2-2.6.4_9
        py27-gtk2-2.24.0_5
        gnome-vfs-2.24.4_10
        libcanberra-0.30_4
        policykit-gnome-0.9.2_8
        libgnome-2.32.1
        libgnomecanvas-2.30.3_4
        gnome-mount-0.8_13
        libbonoboui-2.24.5_1
        libgnomeui-2.24.5
        py27-gnome-2.28.1_8
        gourmet-0.17.4_5
        avahi-gtk-0.7_1
        webkit-gtk2-2.4.11_19
        py27-poppler-0.12.1_12
        xscreensaver-5.42
        palemoon-27.9.4_4
        libreoffice-6.0.7_6
        inkscape-0.92.3_8
        webkit2-gtk3-2.22.6
        plasma5-kde-gtk-config-5.15.2
        wx30-gtk3-3.0.4_6
        firefox-esr-60.5.2_1,1
        driconf-0.9.1_12
        gvfs-1.30.4
        avahi-0.7
        gnome-online-accounts-3.28.0_1
        plasma5-plasma-5.15.2
        audacity-2.3.0_4
        libgdata-0.17.9
        kde5-5.15.2.18.12.2

Number of packages to be removed: 35
The operation will free 1 GiB.
Proceed with deinstalling packages? [y/N]: n
I used pkg delete -f gtk2-2.24.32 to just delete gtk. Audacity started and ran correctly but most everything else on the list failed. Do we have to ween our user-land of dated dependencies ourselves, or, is this a bigger problem? What I mean is if I delete all these including gtk2 will they all auto-magically switch to gtk3 when I rebuild?
Thanks for that! Isn't there a way to disable gtk2 deps in audacity? I looked at the Makefile and found nothing. I don't want to break my system for it. Might as well wait for a fix if no possible.
 

tedbell

Member

Reaction score: 39
Messages: 99

EDIT:
I got audacity working by uninstalling gtk2 with deps then building audacity again followed by the ports and deps that required gtk2. Not sure what the deal was with that.
 

YuryG

Well-Known Member

Reaction score: 18
Messages: 347

EDIT:
I got audacity working by uninstalling gtk2 with deps then building audacity again followed by the ports and deps that required gtk2. Not sure what the deal was with that.
I have the same problem. And I totally do not want to deinstall all that staff! (For me it is 200+ ports! Many of which are heavy and used daily.) Is there any other way?
Code:
(Audacity:31278): Gtk-ERROR **: 17:30:23.542: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
Trace/BPT trap (core dumped)
And by the way, no trouble mentioned in /usr/ports/UPDATING at all!
 

tedbell

Member

Reaction score: 39
Messages: 99

I have the same problem. And I totally do not want to deinstall all that staff! (For me it is 200+ ports! Many of which are heavy and used daily.) Is there any other way?
Code:
(Audacity:31278): Gtk-ERROR **: 17:30:23.542: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
Trace/BPT trap (core dumped)
And by the way, no trouble mentioned in /usr/ports/UPDATING at all!
I'm not sure what I did that fixed it. Pkg reports that it wants to reinstall it because of a dependency change so maybe that dependency change was fixed by an uninstall/rebuild/reinstall. I'm afraid all I can suggest besides my post in to contact the maintainer. it didn't work when I just uninstalled audacity and rebuilt from ports.
 

fernandel

Aspiring Daemon

Reaction score: 171
Messages: 737

And I have just:
Code:
Installed packages to be REMOVED:
    webkit-gtk2-2.4.11_19
    gimp-app-2.10.8_1,1
    claws-mail-fancy-3.17.3
    gimp-gutenprint-5.2.14
    py27-gimp-2.10.8_1
    gimp-2.10.8,2
And I have now:
Code:
Checking all packages: 100%
claws-mail-fancy has a missing dependency: webkit-gtk2
claws-mail-fancy is missing a required shared library: libwebkitgtk-1.0.so.0
claws-mail-fancy is missing a required shared library: libjavascriptcoregtk-1.0.so.0
gimp-app has a missing dependency: webkit-gtk2
gimp-app is missing a required shared library: libwebkitgtk-1.0.so.0
gimp-app is missing a required shared library: libjavascriptcoregtk-1.0.so.0
but everything works as before.
And the problem is solved with deleteting mail/claws-mail-fancy which I didn't use and rebuild graphics/gimp-app
 
OP
OP
Minbari

Minbari

Well-Known Member

Reaction score: 169
Messages: 322

And I have just:
Code:
Installed packages to be REMOVED:
    webkit-gtk2-2.4.11_19
    gimp-app-2.10.8_1,1
    claws-mail-fancy-3.17.3
    gimp-gutenprint-5.2.14
    py27-gimp-2.10.8_1
    gimp-2.10.8,2
And I have now:
Code:
Checking all packages: 100%
claws-mail-fancy has a missing dependency: webkit-gtk2
claws-mail-fancy is missing a required shared library: libwebkitgtk-1.0.so.0
claws-mail-fancy is missing a required shared library: libjavascriptcoregtk-1.0.so.0
gimp-app has a missing dependency: webkit-gtk2
gimp-app is missing a required shared library: libwebkitgtk-1.0.so.0
gimp-app is missing a required shared library: libjavascriptcoregtk-1.0.so.0
but everything works as before.
I'm guessing you received those messages because www/webkit2-gtk3 depends on x11-toolkits/wxgtk31 (wxWidgets) by default since version 3.1.1. And if you installed programs with ports-mgmt/pkg there webkit2 is enabled by default and has some gtk2 depencencies which conflicts with gtk3.

Anyways since the initial problem was solved I will mark this thread as solved.
 
Top