Audacious on FreeBSD 13.0

coyote_trackz

Member

Reaction score: 2
Messages: 57

I just did a fresh install of FreeBSD 13.0 and installed mate. When I went to install audacious so that I could play some music I noticed that the only audacious packages that show up are audacious-4.1, audacious-gtk2-4.1 and audacious-skins-0.4. I thought this was a little weird since on 12.2 there was also a package for audacious-plugins (both standard and for gtk2).
I tried installing audacious to see if the plugins were no longer needed but when I tried to run audacious from the command line I got an error about the plugins being needed. Is this something I should submit a bug for? I haven't found one listed yet but wanted to make sure I'm not missing something.
 

reddy

Active Member

Reaction score: 67
Messages: 112

Indeed, I installed audacious just a few days ago on 12.2 but there was no audacious-plugins package there too, I had to build it from source using the ports tree. I didn't file a bug report as far as i am concerned, but it may be a good idea to do so if nobody did.
 

Emrion

Aspiring Daemon

Reaction score: 178
Messages: 623

Actually, the plugins are absent from the quarterly repo, but they are present on the latest one. I think it's a matter of time before they appear on the quarterly.
 

Tieks

Member

Reaction score: 37
Messages: 88

I'm doing a fresh install of FBSD 13 too at the moment, but I have both /usr/ports/multimedia/audacious and /usr/ports/multimedia/audacious-plugins. Is your ports tree up-to-date? Try portsnap fetch / update. The ports tree on the install medium may not be up-to-date.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 11,241
Messages: 37,415

Audacious and the plugins were skipped on quarterly because a dependency had fetch errors.

Code:
=> libsidplayfp-2.1.1.tar.gz is not in /usr/ports/audio/libsidplayfp/distinfo.
=> Either /usr/ports/audio/libsidplayfp/distinfo is out of date, or
=> libsidplayfp-2.1.1.tar.gz is spelled incorrectly.
*** Error code 1

Stop.
make: stopped in /usr/ports/audio/libsidplayfp
 
Top