ATI Radeon X1200 no reported acceleration

Hello,

I am having some seemingly difficulties with an ATI Radeon X1200 chip.

Under FreeBSD it is reportedly failing to enable hardware acceleration for the chip. Under Linux (Lubuntu) the acceleration is enabled.

I do have a xorg.conf but it is stripped down to just identifying the correct driver and trying to force turn on acceleration: http://pastebin.com/zTdM1410

The resulting Xorg.0.log: http://pastebin.com/wqYgHy25

For comparison the Linux generated Xorg.0.log: http://pastebin.com/Lywk45qv

A summation of errors and warnings for Xorg are given below:
Code:
[   282.494] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   282.760] (WW) RADEON(0): Direct rendering disabled

[   282.761] (EE) AIGLX: reverting to software rendering
[   283.075] (EE) RADEON(0): drmmode_do_crtc_dpms cannot get last vblank counter

Any help greatly appreciated!
 
Code:
[LIST=1]
[*][   282.760] (WW) RADEON(0): Direct rendering disabled
[*][   282.760] (II) RADEON(0): Acceleration disabled
[/LIST]

You may need to add your user to the group 'video'.
 
OK, please give us the output of:
Code:
ls -l /dev/dri
kldstat
 
Hi,

As requested:
Code:
% ls -l /dev/dri
total 0
crw-rw----  1 root  video  0x6f Jan 13 12:55 card0
crw-rw----  1 root  video  0x6e Jan 13 12:55 controlD64

and

Code:
% kldstat
Id Refs Address            Size     Name
 1   60 0xffffffff80200000 1fa7c38  kernel
 2    1 0xffffffff821a9000 30aec0   zfs.ko
 3    2 0xffffffff824b4000 adc0     opensolaris.ko
 4    1 0xffffffff824bf000 7278     ums.ko
 5    1 0xffffffff824c7000 1620     accf_data.ko
 6    1 0xffffffff824c9000 18d0     accf_dns.ko
 7    1 0xffffffff824cb000 2710     accf_http.ko
 8    1 0xffffffff824ce000 8780     acpi_video.ko
 9    1 0xffffffff824d7000 3a78     cc_htcp.ko
10    1 0xffffffff82621000 33bec    pf.ko
11    3 0xffffffff82655000 4feed    vboxdrv.ko
12    2 0xffffffff826a5000 2a1f     vboxnetflt.ko
13    2 0xffffffff826a8000 befc     netgraph.ko
14    1 0xffffffff826b4000 423b     ng_ether.ko
15    1 0xffffffff826b9000 3f86     vboxnetadp.ko
16    1 0xffffffff826bd000 116285   radeonkms.ko
17    1 0xffffffff827d4000 55180    drm2.ko
18    4 0xffffffff8282a000 26e8     iicbus.ko
19    1 0xffffffff8282d000 1c75     iic.ko
20    1 0xffffffff8282f000 1e70     iicbb.ko
21    1 0xffffffff82831000 f3d      radeonkmsfw_RS690_cp.ko
 
Your output look OK to me.

Noticed this too in Xorg.0.log:
Code:
[   282.495] (--) RADEON(0): Chipset: "ATI Radeon X1200" (ChipID = 0x791f)
[   282.495] (II) RADEON(0): GPU accel disabled or not working, using shadowfb for KMS
 
I'm at a loss.

Had seen that post before but had another go. Set the card to 777. Loaded smbus, cuse4bsd just to align the configuration. Copied the xorg.conf as a test configuration file. Still getting the same reverting to software rendering for acceleration.

Tried looking at the Xorg modules the Linux loaded, as there was a difference, and telling Xorg to load those just in case.

The only thing I can think of is if there's a propriety bit of code or similar that's required to access the GPU properly. I believe Linux has packages such as "firmware-linux-nonfree".
 
The thread I linked in the previous post suggest to NOT load the modules from loader.conf, can you confirm about ?
 
I think that the reason why acceleration didn't worked in the other thread, loading modules from loader.conf, was because the module drm2 was missing.

You could try to load them from loader.conf, all five modules, in following order:
Code:
radeonkmsfw_RS690cp_load="YES"
iicbb_load="YES"
iic_load="YES"
iicbus_load="YES"
drm2_load="YES"
radeonkms_load="YES"
radeon cards sometimes have initialization issues ... give a try.
 
OK, had a go with that and.....same thing. Even added in
Code:
drm_load="YES"
too just in case.....Disabled the VirtualBox modules too just in case there was interference from those.

Appears 3D acceleration works:
Code:
glxinfo | grep render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.7, 128 bits)
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil,
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_depth_clamp,
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

Currently reading the DRI Wiki.
 
Do I understand correctly ? The issue was related to virtualbox modules ?
 
No, I removed the modules from /boot/loader.conf just in case they were interfering. Reducing the number of kernel modules used to isolate issue.
 
Well, no further forward. I booted the Linux again and inspected what the browsers told me. See if there was a clue in there. Interesting that Firefox reports the Gallium driver.
 

Attachments

  • 2017-01-14-191157_1280x800_scrot.png
    2017-01-14-191157_1280x800_scrot.png
    203 KB · Views: 919
  • 2017-01-14-190024_1280x800_scrot.png
    2017-01-14-190024_1280x800_scrot.png
    122 KB · Views: 477
  • 2017-01-14-193407_1280x800_scrot.png
    2017-01-14-193407_1280x800_scrot.png
    102.9 KB · Views: 471
  • 2017-01-14-193614_1280x800_scrot.png
    2017-01-14-193614_1280x800_scrot.png
    188.2 KB · Views: 468
Back
Top