Atheros AR946x/AR948x and bluetooth

abishai

Aspiring Daemon

Reaction score: 185
Messages: 767

I have Atheros AR946x/AR948x adapter for WiFi, however it has Bluetooth as well. I thought I can switch to bluetooth mouse, so I enabled bluetooth in BIOS.
I added bluetooth_enable="YES" in /etc/rc.conf
Code:
abishai@sphinx:~ % kldstat
Id Refs Address            Size     Name
1   67 0xffffffff80200000 203ea70  kernel
2    1 0xffffffff82240000 75b0     acpi_video.ko
3    1 0xffffffff82248000 381080   zfs.ko
4    2 0xffffffff825ca000 a380     opensolaris.ko
5    1 0xffffffff825d5000 af98     aesni.ko
6    1 0xffffffff825e0000 1e0d8    geom_eli.ko
7    1 0xffffffff825ff000 15da0    fuse.ko
8    1 0xffffffff82615000 8890     ng_ubt.ko
9    2 0xffffffff8261e000 128c0    ng_hci.ko
10    4 0xffffffff82631000 2c20     ng_bluetooth.ko
11    6 0xffffffff82634000 17640    netgraph.ko
12    1 0xffffffff82ffa000 1820     fdescfs.ko
13    1 0xffffffff82ffc000 11d3e7   i915kms.ko
14    1 0xffffffff8311a000 71650    drm.ko
15    4 0xffffffff8318c000 edc8     linuxkpi.ko
16    3 0xffffffff8319b000 d470     linuxkpi_gplv2.ko
17    2 0xffffffff831a9000 6b8      debugfs.ko
18    1 0xffffffff831aa000 27a0     ums.ko
19    1 0xffffffff831ad000 1780     uhid.ko
20    1 0xffffffff831af000 bc0e     ng_l2cap.ko
21    1 0xffffffff831bb000 176a8    ng_btsocket.ko
22    1 0xffffffff831d3000 1d40     ng_socket.ko
23    1 0xffffffff831d5000 9e8      pflog.ko
24    1 0xffffffff831d6000 2e4a8    pf.ko
25    1 0xffffffff83205000 6fc4     tmpfs.ko
Code:
usbus0: waiting for BIOS to give up control
usbus0 on xhci0
usbus0: 5.0Gbps Super Speed USB v3.0
ugen0.1: <0x8086 XHCI root HUB> at usbus0
uhub0: <0x8086 XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus0
Root mount waiting for: usbus0
Root mount waiting for: usbus0
ugen0.2: <Logitech USB Receiver> at usbus0
ukbd0: <Logitech USB Receiver, class 0/0, rev 2.00/12.01, addr 1> on usbus0
Root mount waiting for: usbus0
ugen0.3: <vendor 0x0cf3 product 0xe006> at usbus0
ubt0: <vendor 0x0cf3 product 0xe006, class 224/1, rev 1.10/0.01, addr 2> on usbus0
ums0: <Logitech USB Receiver, class 0/0, rev 2.00/12.01, addr 1> on usbus0
uhid0: <Logitech USB Receiver, class 0/0, rev 2.00/12.01, addr 1> on usbus0
Code:
abishai@sphinx:~ % doas hccontrol read_node_list
Name            ID       Num hooks
ubt0hci         00000007         3
The problem that I can't find anything.
Code:
abishai@sphinx:~ % doas hccontrol -n ubt0hci inquiry
Inquiry complete. Status: No error [00]
I have mouse and android phone, both are in BT discovery mode, so my laptop should see both of them. While phone sees mouse, laptop is not.
Am I missing something?
 
Top