Solved Atheros AR9280 WIFI not working

jhns

New Member


Messages: 2

Hey all! My Wifi is not working. I followed the Quick Start steps in section 31.3 of the manual. I'm running 11.2-RELEASE.

dmesg shows:
Code:
~ » dmesg|grep ath0
ath0: <Atheros 9280> mem 0xf2400000-0xf240ffff at device 0.0 on pci1
ath0: [HT] enabling HT modes
ath0: [HT] 1 stream STBC receive enabled
ath0: [HT] 1 stream STBC transmit enabled
ath0: [HT] 2 RX streams; 2 TX streams
ath0: AR9280 mac 128.2 RF5133 phy 13.0
ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0
ath0: ath_legacy_rx_tasklet: sc_inreset_cnt > 0; skipping
ath0: <Atheros 9280> mem 0xf2400000-0xf240ffff at device 0.0 on pci1
ath0: [HT] enabling HT modes
ath0: [HT] 1 stream STBC receive enabled
ath0: [HT] 1 stream STBC transmit enabled
ath0: [HT] 2 RX streams; 2 TX streaath0: AR9280 mac 128.2 RF5133 phy 13.0
ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0

Here's my rc.conf
Code:
clear_tmp_enable="YES"
syslogd_flags="-ss"
sendmail_enable="NONE"
hostname="fbsdx220"
ifconfig_em0="DHCP"
ifconfig_em0_ipv6="inet6 accept_rtadv"
create_args_wlan0="regdomain XC900M"
moused_enable="YES"
ntpd_enable="YES"
powerd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
dbus_enable="YES"
hald_enable="YES"
gdm_enable="YES"
gnome_enable="YES"
kld_list="/boot/modules/i915kms.ko"
wlans_ath0="wlan0"
ifconfig_wlan0="WPA SYNCDHCP"

When I run ifconfig wlan0 up scan, it sometimes blocks for a while, but shows no output. I'm in the range of a Wifi network, and other clients connect to it fine.

Here's my wpa_supplicant.conf:

Code:
ctrl_interface=/var/run/wpa_supplicant
eapol_version=2
ap_scan=1
fast_reauth=1

network={
    ssid="Bunte Farben"
    psk="****************"
}

When I run service netif restart, I get the following output:

Code:
~ » sudo service netif restart
dhclient not running? (check /var/run/dhclient.em0.pid).
Stopping wpa_supplicant.
Waiting for PIDS: 2303.
dhclient not running? (check /var/run/dhclient.wlan0.pid).
Stopping Network: lo0 em0 wlan0.
lo0: flags=8048<LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    groups: lo 
em0: flags=8c02<BROADCAST,OACTIVE,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC>
    ether f0:de:f1:ed:5f:c9
    hwaddr f0:de:f1:ed:5f:c9
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
wlan0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
    ether 00:22:5f:6d:54:42
    hwaddr 00:22:5f:6d:54:42
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
    status: no carrier
    ssid "" channel 30 (920 MHz 11g/10MHz)
    regdomain XC900M indoor ecm authmode OPEN privacy OFF txpower 30
    bmiss 7 mcastrate 3 mgmtrate 3 scanvalid 60 protmode CTS wme burst
    groups: wlan 
Destroyed wlan(4) interfaces: wlan0.
Created wlan(4) interfaces: wlan0.
wpa_supplicant already running?  (pid=4475).
dhclient already running?  (pid=4493).
Starting Network: lo0 em0 wlan0.
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
    inet6 ::1 prefixlen 128 
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2 
    inet 127.0.0.1 netmask 0xff000000 
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    groups: lo 
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC>
    ether f0:de:f1:ed:5f:c9
    hwaddr f0:de:f1:ed:5f:c9
    inet6 fe80::f2de:f1ff:feed:5fc9%em0 prefixlen 64 scopeid 0x1 
    inet6 2a01:c22:a821:3300:f2de:f1ff:feed:5fc9 prefixlen 64 autoconf 
    nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
    media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    ether 00:22:5f:6d:54:42
    hwaddr 00:22:5f:6d:54:42
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
    status: no carrier
    ssid "" channel 39 (925 MHz 11g/5MHz)
    regdomain XC900M indoor ecm authmode WPA1+WPA2/802.11i privacy MIXED
    deftxkey UNDEF txpower 30 bmiss 7 mcastrate 1.5 mgmtrate 1.5
    scanvalid 60 protmode CTS wme burst roaming MANUAL bintval 0
    groups: wlan

Also, the following messages appeared in dmesg

Code:
ath0: ath_legacy_rx_tasklet: sc_inreset_cnt > 0; skipping
ath0: ath_legacy_rx_tasklet: sc_inreset_cnt > 0; skipping

Do I need a firmware for this device?

I need help ^^
 

k.jacker

Aspiring Daemon

Reaction score: 467
Messages: 740

No firmware needed for the if_ath(4) driver.

status: no carrier
ssid "" channel 39 (925 MHz 11g/5MHz)
Your ssid does not show ,you are missing something in /etc/rc.conf.
Before taking care of this, I'd recommend changing your ssid from Bunte Farben to Bunte_Farben

ifconfig_wlan0="WPA SYNCDHCP"
Change that line in your /etc/r.conf to
Code:
ifconfig_wlan0="WPA SYNCDHCP ssid Bunte_Farben"

After service netif restart your ssid should show inside the doubleqoutes of ifconfig's output, status should show as associated.
 
OP
J

jhns

New Member


Messages: 2

Hey, it turns out the space in the SSID name was not the issue.

I had the wrong regdomain set in rc.conf. I changed it to "ETSI" and now everything works!

It helped posting this to think about it more clearly. Thanks for reading my post :)
 
Top