Atheros 9285 & Atheros AR8131

KsenZ

New Member


Messages: 7

Network cards do not work.
Code:
ath0: <Atheros 9285> irq 19 at device 0.0 on pci7
ath0: 0x10000 bytes of rid 0x10 res 3 failed (0, 0xffffffff).
ath0: cannot map register space
device_attach: ath0 attach returned 6
Code:
alc0: <Atheros AR8131 PCIe Gigabit Ethernet> irq 17 at device 0.0 on pci9
alc0: 0x40000 bytes of rid 0x10 res 3 failed (0, 0xffffffff).
alc0: cannot allocate memory resources.
device_attach: alc0 attach returned 6
How can I make them work?
 
OP
KsenZ

KsenZ

New Member


Messages: 7

Forgot to say, tried on systems 8.0, 8.1, and 8.2. Notebook Aser Extenza 5635ZG.
 
OP
KsenZ

KsenZ

New Member


Messages: 7

Tried to change Wi-Fi adapter on the other, but the situation has not changed
Code:
cannot map register space
 

tingo

Daemon

Reaction score: 487
Messages: 2,270

This is a hard problem to fix. Somehow, FreeBSD isn't configuring the internal devices in your laptop correctly. Some options:

  1. Try to boot with acpi disabled, and see if it works then. Note: many modern laptops need acpi to have their thermal monitoring work correctly; be careful, you might overheat you laptop if it runs for too long with acpi disabled.
  2. Search (Google is your friend) and see if anyone else has fixed those problems.
  3. Look at linux boot messages (or /var/log/messages) and lspci output for your network cards; try to figure out how Linux is mapping your device; what irq's, irq routing, memory allocation etc. Then compare that to what FreeBSD does. If you notice that FreeBSD is doing it differently, try to ask (here or on the freebsd-mobile mailinglist) how you can configure FreeBSD to do it the same way Linux does it. Be specific, include as much (relevant) details as possible.
 

cheme

New Member

Reaction score: 3
Messages: 15

Hello,

Are you running the standard generic kernel? If you are then you need to load the modules for the wireless card and the Ethernet port. There is also some additional configuration that needs to take place to connect automatically when you boot your machine.

Try adding or changing your settings to match up with these in the following configuration files.


This tells FreeBSD to load the modules for both the wireless and the Ethernet adapter.

Code:
[B]/boot/loader.conf[/B]

If_alc_load=”YES”  

If_ath_load=”YES”

This tells FreeBSD to use DHCP for both the wireless and Ethernet adapters.

Code:
[B]/etc/rc.conf[/B]

Hostname=”yourhostname”

ifconfig_alc0=”DHCP”

wlans_ath0=”wlan0”

ifconfig_wlan0=”DHCP”

This is the address of my router, your configuration may be different.


Code:
[B]/etc/resolv.conf
[/B]
Nameserver  192.168.1.1


Reboot your system.



If you want to use wpa_supplicant to protect your wireless network try the following link and check out my configuration to connect to a wpa and/or a wep encrypted network. http://forums.freebsd.org/showthread.php?t=21206. If it does not help perform a search on this forum or the net using your favorite search engine you will find a ton of information on setting up your system.

Also you should check out the FreeBSD handbook section on wireless networking. http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-wireless.html

Good Luck
 

cheme

New Member

Reaction score: 3
Messages: 15

I made an editing mistake in the previous post.

Make sure to use lower case in all of the configuration files except for the "YES" at the end of the line in /boot/loader.conf

Example:
Code:
if_ath_load="YES"
hostname="yourhostname"
Good Luck
 
OP
KsenZ

KsenZ

New Member


Messages: 7

tingo said:
This is a hard problem to fix. Somehow, FreeBSD isn't configuring the internal devices in your laptop correctly. Some options:

  1. Try to boot with acpi disabled, and see if it works then. Note: many modern laptops need acpi to have their thermal monitoring work correctly; be careful, you might overheat you laptop if it runs for too long with acpi disabled.
  2. Search (Google is your friend) and see if anyone else has fixed those problems.
  3. Look at linux boot messages (or /var/log/messages) and lspci output for your network cards; try to figure out how Linux is mapping your device; what irq's, irq routing, memory allocation etc. Then compare that to what FreeBSD does. If you notice that FreeBSD is doing it differently, try to ask (here or on the freebsd-mobile mailinglist) how you can configure FreeBSD to do it the same way Linux does it. Be specific, include as much (relevant) details as possible.
Google does not know the answer :)
irq's identical.

cheme said:
Hello,

Are you running the standard generic kernel? If you are then you need to load the modules for the wireless card and the Ethernet port. There is also some additional configuration that needs to take place to connect automatically when you boot your machine.

...

If you want to use wpa_supplicant to protect your wireless network try the following link and check out my configuration to connect to a wpa and/or a wep encrypted network. http://forums.freebsd.org/showthread.php?t=21206. If it does not help perform a search on this forum or the net using your favorite search engine you will find a ton of information on setting up your system.

Also you should check out the FreeBSD handbook section on wireless networking. http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-wireless.html

Good Luck
I know this, but it does not solve the problem. I think that the problem in ACPI(or anything else) in FreeBSD
 

cheme

New Member

Reaction score: 3
Messages: 15

I did some searching and found some information on the mailing lists and a bug report.

It appears that you filled a bug report on August 5th 2010, PR kern/149306. Well, it's the same user name. I could not find a resolution to the bug report so that was a dead end.

Check out the following link. http://mail-index.netbsd.org/current-users/2010/06/08/msg013697.html. The mailing list is about the AR9285 and AR8132 ethernet adapter. It may lead you in the right direction with some additional research and/or internet searching.

One last thought, have you tried 9.0? Here is a link to the ftp site. ftp://ftp.freebsd.org/pub/FreeBSD/snapshots/201101/

Good Luck
 
OP
KsenZ

KsenZ

New Member


Messages: 7

response from the mailinglist ACPI:
This is probably due to a problem FreeBSD has with ACPI initialization
sometimes wiping out the state in PCI-PCI bridges for resource windows and not
gracefully recovering from that. I have some early work in progress to
address this, but it will be a while before I have something ready for
testing.
 
Top