Anydesk on FreeBSD 13.1

SirDice

Administrator
Staff member
Administrator
Moderator
Third-party software. Package is not from a port or official package. They're creating their own packages. Maybe read the documentation that comes with it?

Or use deskutils/anydesk?
 
last time I checked the port only pulls the binary, so you can also just manually download the latest version and use that.
HOWEVER: of course you still need to have all dependencies installed, so using the port as a starting point might be a good idea as it installs all dependencies and IIRC tells you what other conditions have to be met (e.g. procfs needs to be mounted)

You can also just run the precompiled binary and look at the error messages to find out whats missing...
 
Start the binary (or script?) from a shell and observe the output. It might give some hints.
$ anydesk
ld-elf.so.1: Shared object "libgtkglext-x11-1.0.so.0" not found, required by "anydesk"

pkg does not find any libgtkglext

So I find it in ports by installing /x11-toolkits/gtkglext/.

Now it works from GUI, I can connect but it remains on "waiting for getting of image" from the remote side and doesnt pass that window.
 
Now it works from GUI, I can connect but it remains on "waiting for getting of image" from the remote side and doesnt pass that window.

Are you trying to connect to a windows 10 client? there has to be a user logged in and the screen mustn't be locked. sometimes even sending the monitor to standby causes win10 to block any incoming connections...

A slow internet connection may also lead to timeouts or at least a very long delay until you get any image. I'm dealing with this regularly when trying to assist my mother-in-law through her crappy telekom DSL line.
 
Are you trying to connect to a windows 10 client? there has to be a user logged in and the screen mustn't be locked. sometimes even sending the monitor to standby causes win10 to block any incoming connections...

A slow internet connection may also lead to timeouts or at least a very long delay until you get any image. I'm dealing with this regularly when trying to assist my mother-in-law through her crappy telekom DSL line.

I am trying to connect from my Tablet to my Computer.
 
I don't know if "silent" connections (without the remote site accepting the connection) is possible with the unpaid version.
We only use the paid variant, where you can generate a custom installer for clients and restrict them to only incoming connections with a preset password and allowing silent connections by default. I'm also only connecting from my FreeBSD workstation or laptop to various windows clients, not the other way around, so I usually start anydesk as needed, but you could just run it via your users .xinitrc at login
 
Top