Ansible error py37-supervisor have been found in the repositories

My ansible role looks like this:
YAML:
---
- name: Download supervisord
  pkgng:
    name:
      - py37-supervisor
    state: present
After executing this role, it returns
Bash:
fatal: [1.2.3.4]: FAILED! => {"changed": false, "msg": "failed to install py37-supervisor: ", "stderr": "pkg: No packages available to install matching 'py37-supervisor' have been found in the repos}
How can I fix this error?


When I ssh to my machine as root and try to execute `pkg -d install py37-supervisor`, I am getting a similar error:
Bash:
DBG(1)[15274]> pkg initialized
Updating FreeBSD repository catalogue...
DBG(1)[15274]> PkgRepo: verifying update for FreeBSD
DBG(1)[15274]> Pkgrepo, begin update of '/var/db/pkg/repo-FreeBSD.sqlite'
DBG(1)[15274]> Request to fetch pkg+[URL]http://pkg.FreeBSD.org/FreeBSD:11:amd64/quarterly/meta.conf[/URL]
DBG(1)[15274]> opening libfetch fetcher
DBG(1)[15274]> Fetch > libfetch: connecting
DBG(1)[15274]> Fetch: fetching from: [URL]http://pkgmir.geo.freebsd.org/FreeBSD:11:amd64/quarterly/meta.conf[/URL] with opts "i"
DBG(1)[15274]> Request to fetch pkg+[URL]http://pkg.FreeBSD.org/FreeBSD:11:amd64/quarterly/packagesite.txz[/URL]
DBG(1)[15274]> opening libfetch fetcher
DBG(1)[15274]> Fetch > libfetch: connecting
DBG(1)[15274]> Fetch: fetching from: [URL]http://pkgmir.geo.freebsd.org/FreeBSD:11:amd64/quarterly/packagesite.txz[/URL] with opts "i"
FreeBSD repository is up to date.
All repositories are up to date.
DBG(1)[15274]> want to get an advisory lock on a database
pkg: No packages available to install matching 'py37-supervisor' have been found in the repositories
DBG(1)[15274]> release an advisory lock on a database


My machine is running on `FreeBSD FreeBSD 11.4-RELEASE-p9 FreeBSD 11.4-RELEASE-p9`

I would like to add that command pkg install py38-supervisor works fine. But it does not solve my problem because I need 3.7 version
 

SirDice

Administrator
Staff member
Administrator
Moderator
The default python changed from 3.7 to 3.8 on the latest quarterly repositories.
 

SirDice

Administrator
Staff member
Administrator
Moderator
Why do you need the 3.7 version? The default changed, so all python modules (including sysutils/ansible) will depend on 3.8.

Code:
---
- name: Download supervisord
  pkgng:
    name:
      - py37-supervisor
    state: present
Change it to
Code:
---
- name: Download supervisord
  pkgng:
    name:
      - sysutils/py-supervisor
    state: present
 
Top