Solved After upgrading bind916

Code:
/etc/rc.d/named: WARNING: named_pidfile: now determined from the conf file
What can I do to prevent this message from appearing after the daemon is restarted?
 

SirDice

Administrator
Staff member
Administrator
Moderator
You shouldn't have a /etc/rc.d/named:
Code:
dice@maelcum:~ % ll /etc/rc.d/named
ls: /etc/rc.d/named: No such file or directory
dice@maelcum:~ % pkg info -x bind
bind-tools-9.18.5
bind916-9.16.31
dice@maelcum:~ % ll /usr/local/etc/rc.d/named
-rwxr-xr-x  1 root  wheel  12409 Jul 24 02:14 /usr/local/etc/rc.d/named*
dice@maelcum:~ % freebsd-version -uk
13.1-RELEASE
13.1-RELEASE
 
My named only is in
Code:
/usr/local/etc/rc.d/named
pkg info -x bind
bind-tools-9.18.5
bind916-9.16.31

But I didn't get this message until today's bin916 update
 

SirDice

Administrator
Staff member
Administrator
Moderator
The error is from /etc/rc.d/named, which shouldn't even exist.
 
So what should I do to prevent this message from appearing again? Waiting for a new update?
 

SirDice

Administrator
Staff member
Administrator
Moderator
What does ls -l /etc/rc.d/named /usr/local/etc/rc.d/named show?
 
Code:
ls -l /etc/rc.d/named /usr/local/etc/rc.d/named
-rwxr-xr-x  1 1005  ku     12409 Apr 13 14:52 /etc/rc.d/named
-rwxr-xr-x  1 root  wheel  12409 Jul 23 22:32 /usr/local/etc/rc.d/named
 

SirDice

Administrator
Staff member
Administrator
Moderator
So, someone created /etc/rc.d/named. That shouldn't be there, remove it.
 
I deleted.
Code:
ls -l /etc/rc.d/named /usr/local/etc/rc.d/named
ls: /etc/rc.d/named: No such file or directory
-rwxr-xr-x  1 root  wheel  12409 Jul 23 22:32 /usr/local/etc/rc.d/named
Did not help
Code:
service named restart
Stopping named.
Waiting for PIDS: 68802.
/usr/local/etc/rc.d/named: WARNING: named_pidfile: now determined from the conf file
Starting named.
 
But pid exists
Code:
/var/run/named# ls -l /var/run/named
total 8
-rw-r--r--  1 bind  bind    6 Jul 27 13:17 pid
-rw-------  1 bind  bind  102 Jul 27 13:17 session.key
 

SirDice

Administrator
Staff member
Administrator
Moderator
Stop the service, things probably got wacked because you had two different rc.d(8) scripts for the service. After service named stop check there are no named(8) processes running, kill them if you have to. After making sure there's really nothing running any more you can start the service; service named start.
 
Stop the service, things probably got wacked because you had two different rc.d(8) scripts for the service. After service named stop check there are no named(8) processes running, kill them if you have to. After making sure there's really nothing running any more you can start the service; service named start.
No, that's not it. It seems to me that in archlinux I manually prescribe the path so that named uses pid and not conf
 
In freebsd it seems 11 I had such a message and I also prescribed something but I can’t find a topic with this question in your forum
 
In freebsd it seems 11 I had such a message and I also prescribed something but I can’t find a topic with this question in your forum.
I was under a different name
 

SirDice

Administrator
Staff member
Administrator
Moderator
PID file is set in named.conf:
Code:
options {
{...}
        pid-file        "/var/run/named/pid";
{...}

Did you add any flags in /etc/rc.conf with named_flags? What does grep named_ /etc/rc.conf output?
 
Code:
sudo service named stop
Password:
Stopping named.
Waiting for PIDS: 69083.
pal@boss:~ % sudo service named start
/usr/local/etc/rc.d/named: WARNING: named_pidfile: now determined from the conf file
Starting named.
 
Before today's upgrade, I haven't seen such a message for three years. There was such a message in version 11 after the upgrade
 
Code:
grep named_ /etc/rc.conf 
named_enable="YES"
named_program="/usr/local/sbin/named"
named_conf="/usr/local/etc/namedb/named.conf"
named_pidfile="/var/run/named/pid"
named_uid="bind"
named_flags="-4"
 
named.conf
Code:
options {
        // All file and path names are relative to the chroot directory,
        // if any, and should be fully qualified.
        directory       "/usr/local/etc/namedb/working";
        pid-file        "/var/run/named/pid";
        dump-file       "/var/dump/named_dump.db";
        statistics-file "/var/stats/named.stats
";
Maybe this message is a bug that goes from bind's version to version, then appears and then disappears?
 
I commented in rc.conf
Code:
#named_pidfile="/var/run/named/pid"
Now everything is ok
Code:
sudo service named restart
Stopping named.
Waiting for PIDS: 1090.
Starting named.
Thanks
 
Top