advanced bios settings help

clawhammer

Active Member

Reaction score: 6
Messages: 182

I found this https://www.intel.com/content/www/us/en/support/articles/000006903/graphics-drivers.html. It states that in the desktop bios I can disable the integrated intel graphics. Is this tied into the windows os? because I can only get basic bios settings with the delete key. It mentions hitting f2 but that just brings up a freebsd boot prompt. Does anyone know if when I installed freebsd it over wrote the desktop bios? Thanks.
 
OP
clawhammer

clawhammer

Active Member

Reaction score: 6
Messages: 182

Actually in the FreeBSD computer world there are now two F2's at boot!
The one you are seeing is FreeBSD F2 from boot0cfg(8).

You need to hit F2 earlier in the process. Some boards still use DEL or F2 so keep that in mind.
The best chance of catching the bios before booting to boot0cfg is from a cold start.
Reboots on some are harder to get to BIOS.
Basically listen for the beep. That is sometimes too late. Look at the screen. Some OEM'er do hide/mask it.
Tap the F2 gently every 1 to 2 seconds. Not rapid.

Regarding why you need to enter the BIOS, is this regarding Optimus?(dual intel/nvidia video)
Because on newer boards the video is never really 'disabled'.
As long as its built into the cores FreeBSD will find it.
Example:APU2 is headless serial only box. I can show you dmesg that would shows it has video output.
So unless no video on cores then you need to address by the OS to truly disable.
BIOS setting are more for Windows Optimus driver. Directs it which display to use for Windows.
Ive been trying everything to get xorg to use the nvidia card because the log file shows it finds 2 primary pci gpus and its using the intel one. When i say to use the nvidia one xserver fails saying no screen found.
 

Phishfry

Beastie's Twin

Reaction score: 2,572
Messages: 5,457

Yes and that is where you need to be working on the problem. I figured I would save you some time.
You can not disable the video. You can only direct Xorg to the proper output device. That might take some experimentation.
 
OP
clawhammer

clawhammer

Active Member

Reaction score: 6
Messages: 182

Yes and that is where you need to be working on the problem. I figured I would save you some time.
You can not disable the video. You can only direct Xorg to the proper output device. That might take some experimentation.

Ive been modifying rc.conf loader.conf xorg.conf.d/nvidia-driver. Am i missing something?
 

shkhln

Daemon

Reaction score: 918
Messages: 2,141

desktop bios

Would you mind not calling your Optimus laptop a desktop? And stick to one thread per issue maybe?

When i say to use the nvidia one xserver fails saying no screen found.

That's completely correct because your Nvidia card is not connected to your notebook's display. If you want to use it, you'll have to run 2 Xorg servers in parallel (with different configs for Intel and Nvidia) and copy rendered images from one Xorg server to another for displaying. See https://wiki.freebsd.org/Graphics/OptimusVideoSupport.
 
OP
clawhammer

clawhammer

Active Member

Reaction score: 6
Messages: 182

Would you mind not calling your Optimus laptop a desktop? And stick to one thread per issue maybe?



That's completely correct because your Nvidia card is not connected to your notebook's display. If you want to use it, you'll have to run 2 Xorg servers in parallel (with different configs for Intel and Nvidia) and copy rendered images from one Xorg server to another for displaying. See https://wiki.freebsd.org/Graphics/OptimusVideoSupport.

i installed the port like it said and nothing changed. I tried to search on how to run xservers in parallel but I don't see anything. The wiki you sent said to install the port and nothing else. Are there instructions somewhere? should I do the old approach?
 

shkhln

Daemon

Reaction score: 918
Messages: 2,141

As far as I can see only the first 3 steps of the "Old approach" are obsoleted by the "New approach". The fourth step would need some correction, nvidia-driver no longer replaces libGL.so.1 symlink, but rather it provides a config file for ld-elf.so.1 in /usr/local/etc/libmap.d/nvidia.conf.
 
OP
clawhammer

clawhammer

Active Member

Reaction score: 6
Messages: 182

thanks. How do you find this information?

I dont know how to find this stuff. I try googling things but I must be searching the wrong topics.
 
Top