Adjust time when dual booting with Windows 10 (CMOS clock set to local time)

bertalanp99

New Member


Messages: 7

AFAIK, FreeBSD prefers the hardware (CMOS) clock to be set to UTC, but it is possible to select that it is set to local time during the installation.

That is what I did, as I am dual booting (actually, triple) FreeBSD with Windows 10 (and Void Linux). Now the time displayed is incorrect in FreeBSD.

What is the proper way to adjust it? Shouldn't this

Code:
# Adjust the time zone if the CMOS clock keeps local time, as opposed to
# UTC time.  See adjkerntz(8) for details.
1,31    0-5     *       *       *       root    adjkerntz -a
crontab entry take care of this every half hour? My timezone has been set to CET, correctly (I live in Hungary).
 
OP
OP
bertalanp99

bertalanp99

New Member


Messages: 7

Code:
     /etc/wall_cmos_clock  Empty file.  Its presence indicates that the
                           machine's CMOS clock is set to local time, while
                           its absence indicates a UTC CMOS clock.
From adjkerntz(8)
That file exists on my system. The time is still incorrect :/

IMO, it's more logical to tell Windows that the RTC is in UTC:
Code:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
"RealTimeIsUniversal"=dword:00000001
Thank you, I guess this really is a more logical solution!
 
Top