Adding terminus-font to xorg.conf

Hi everybody, I installed terminus-font and want to activate it. I am using version 10.3

I googled, and did:

# X -configure

I got this:
# X -configure
Fatal server error:
(EE) Server is already active for display 0
   If this server is no longer running, remove /tmp/.X0-lock
   and start again.
Please consult the The X.Org Foundation support
for help.

I thought I was going to get a /root/, copy it to /etc/X11/xorg.conf and add the terminus-font to the font path.

What am I doing wrong?
Just add it to the Files section, similar to the other fonts:
Section "Files"
        ModulePath   "/usr/local/lib/xorg/modules"
        FontPath     "/usr/local/lib/X11/fonts/misc/"
        FontPath     "/usr/local/lib/X11/fonts/TTF/"
        FontPath     "/usr/local/lib/X11/fonts/OTF/"
        FontPath     "/usr/local/lib/X11/fonts/Type1/"
        FontPath     "/usr/local/lib/X11/fonts/100dpi/"
        FontPath     "/usr/local/lib/X11/fonts/75dpi/"
        FontPath     "/usr/local/lib/X11/fonts/cyrillic/"
        FontPath     "/usr/local/lib/X11/fonts/webfonts/"
        FontPath     "/usr/local/lib/X11/fonts/dejavu/"
        FontPath "/usr/local/lib/X11/fonts/terminus-font/"
Nope! I put it in my .xinitrc, and rebooted to make sure, it doesn't show in Firefox :(
Can you show us your .xinitrc?

Also see Thread 55393/#post-313886:
Any app that uses fontconfig (Firefox does) should pick up the bitmap version of Terminus. But Java apps seem to not support bitmap fonts which is why I created the x11-fonts/terminus-ttf port.

Do you have 70-no-bitmaps.conf in /usr/local/etc/fonts/conf.d? It disables all bitmap fonts. If you do you can probably create an exception for Terminus. An example is in Thread 2021.

x11-fonts/terminus-font should be preferred over x11-fonts/terminus-ttf because the TTF version degrades badly and only looks good at certain sizes (see the port's pkg message).
Do try it with x11-fonts/terminus-ttf too if all else fails.
tobik: I installed the terminus-font-ttf and put it in my .xinitrc and rebooted, and this time it appeared on the fonts list in Firefox. Thank you very much!
setxkbmap es
firefox &
xset + fp /usr/local/share/fonts/terminus-font-TTF
setxkbmap -option terminate:ctrl_alt_bksp
xsetroot -solid black
unclutter -idle 2 &
numlockx &

exec jwm

Sir Dice:
Before I follow your advice, I have to be able to create an xorg.conf file which I cannot, and was my first question: How do I create /etc/X11/xorg.conf? I would like to add some other things. Thank you!