Access/modification time set failed on: ./var/empty

timypcr

Member

Reaction score: 6
Messages: 37

Hello,

I run three jails on a FreeBSD 11-release host, and manage them with ezjail. One of the jails generates an error when attempting to archive it.

Code:
ezjail-admin stop reminder

ezjail-admin archive reminder

pax: Access/modification time set failed on: ./var/empty <Operation not permitted>
Warning: Archiving jail reminder was not completely successful.\n  Please refer to the output above for problems the archiving tool encountered.\n  You may ignore reports concerning setting access and modification times.\n  You might want to check and remove /usr/jails/ezjail_archives/reminder-201701300002.32.tar.gz.Warning: Archiving jail reminder was not completely successful. For a running jail this is not unusual.
I tried running
Code:
chflags noschg /var/empty
on the host but still the error occurs.

How can I resolve this issue?

Thanks,

Tim
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,879
Messages: 31,151

It's an empty, read-only directory.
 
OP
OP
timypcr

timypcr

Member

Reaction score: 6
Messages: 37

So the message should be ignored? how come none of my other jails shows this error when archiving?
 

nforced

Member

Reaction score: 10
Messages: 87

I get the same warning for one of my jails.
This warning was not present in the past and no modifications have been made by me.
1. does anyone know when/why this started
2. how to suppress?

Please advice
 

Mikalai

Member


Messages: 27

I have the same thing on all jails .

The real question is in the second part of the message:
Warning: Archiving jail reminder was not completely successful.​

I am not supposed to assume that a mere empty folder will not be an impediment to a successful recovery from an archive.
This is definitely needs to be addressed. But where? Which bug place? What code base is responsible for this?
 
OP
OP
timypcr

timypcr

Member

Reaction score: 6
Messages: 37

I'm sorry I never updated this post, so in short what I did was, attempt to restore the jails from said archives and I found that the restore worked without an issue. Its just an empty folder and a seemingly useless message about it.

Thanks,
Tim
 
Top