1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

About dbus_enable.

Discussion in 'GNOME' started by fender0107401, Nov 19, 2008.

  1. fender0107401

    fender0107401 Member

    Messages:
    303
    Thanks Received:
    10
    Hello everyone:

    I have a problem about the dbus_enable option in the /etc/rc.conf.

    According to this page: http://www.freebsd.org/gnome/docs/halfaq.html

    I think I can add gnome_enable="YES" to my /etc/rc.conf to set up everything, but the system show me some massage, when it startup:

    Why? It is a bug or something else? :(

    To solve this problem, I add dbus_enable="YES" to my /etc/rc.conf, and the warning is gone. :e

    System Information:

     
  2. good-beastie

    good-beastie New Member

    Messages:
    19
    Thanks Received:
    1
    rc.conf ~Manual settings with gdm_enable...

    Hi,

    I did have that same log message with a port build of Gnome2,
    on amd64. So i did what I call the 'gnome_gdm manual override' in rc.conf.

    add

    #
    gdm_enable="YES"
    hald_enable="YES"
    dbus_enable="YES"
    avahi_daemon_enable="YES"
    avahi_dnsconfd_enable="YES"
    polkitd_enable="YES"
    system_tools_backends_enable="YES"
    #
    #thats all done without gnome_enable="YES"

    the system_tools_backends is for some gnome confg programs i believe.
     
  3. kamikaze

    kamikaze New Member

    Messages:
    366
    Thanks Received:
    65
    The gnome_enable thing is a hack in the relevant rc-scripts and it must have broken for hald. The script looks all right to me, though.
     
  4. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,854
    Thanks Received:
    2,487
    As of some time ago you can remove the system_tools_backends_enable and polkitd_enable as they aren't needed anymore.

    You also don't really need avahi_dnsconfd..

    Look in /usr/local/etc/rc.d all startup scripts for ports live there.