A lot of softwares could not work after upgrade xorg to 7.4

dybnu

New Member


Messages: 11

I use msn for work,but after the upgrade,none of them can work,i have tried pidgin,amsn, emesene,or even empathy.And there even were no error messages.

so did same on awesome,a wm,that i have to use fluxbox instead.I can only find a error message said"Xlib: extension "Generic Event Extension" missing on display ":0.0"."

by the way ,i upgrade the ports,using the pkg only mode in portupgrade
 

trev

Daemon

Reaction score: 292
Messages: 1,015

I doubt that the pre-compiled packages will work with Xorg 7.4. You will need to recompile all your X Window ports from source. The various methods have been documented several times in recent threads especially this one
Xorg 7.4 upgrade - report

You should also have read /usr/ports/UPDATING for relevant updating requirements.
 
OP
dybnu

dybnu

New Member


Messages: 11

OK,I will have a try ,but I always use the pre-compiled packages,rebuild them take too much time though
 

Carpetsmoker

Daemon

Reaction score: 188
Messages: 1,012

Don't mix packages and ports, use either packages or ports, but not both.

You will get problems with port a being linked to library b version 2, but package c is linked to library b version 1.
Package c won't work.

Or:

Package a is linked to library b version 1, but port c is want library b version 2, so you upgrade library b from version 1 to 2, and package a will stop working.

So if you use packages, and you want to use Xorg 7.4, then you must wait until packages are available.
 
OP
dybnu

dybnu

New Member


Messages: 11

yes,i always use packages,when i saw the xorg 7.4 packages were available,i made the upgrade.It was really a nightmare,i think...
 
OP
dybnu

dybnu

New Member


Messages: 11

OK ,i tried “#portmaster -f awesome”,rebuild pidgin
and everything become OK

maybe,libXext or xextproto hurt it
 
Top