2021Q4: audio/openal-soft does not work (likely jack issue)

PMc

Daemon

Reaction score: 685
Messages: 1,381

The usual issues with quarterly. This time:

Code:
ld-elf.so.1: /usr/local/lib/libopenal.so.1: Undefined symbol "jack_error_callback"

This appears when building graphics/blender, which consequentially fails to build. This is a good thing, because other ports also use openal-soft, which appears to be seriously broken:

2021Q3:
Code:
root@vbuild1:~ # openal-info
Available playback devices:
    !!! none !!!
Available capture devices:
    !!! none !!!
Default playback device:
Default capture device:
ALC version: 1.1

!!! Failed to open default device !!!

2021Q4:
Code:
root@vbuild0:~ # openal-info
ld-elf.so.1: /usr/local/lib/libopenal.so.1: Undefined symbol "jack_error_callback"

There is no difference with openal-soft. But there is some difference with jack:
2021Q3:
jackit-0.125.0_12 Low latency audio server
2021Q4:
jackit-1.9.16 Low latency audio server

I know JACK is not among the default options, which may explain why the matter went undetected.
But from looking at the above versions alone, I would consider this a serious change, and I would have expected to find a mention of this in UPDATING.

Looking closer: they changed from jack-1 to jack-2, which is a serious matter. While supposedly ABI-compatible, It is an entirely rewritten software.
 
OP
PMc

PMc

Daemon

Reaction score: 685
Messages: 1,381

This appears to be a known bug: PR 257696
(There is a workaround patch in the bug. So let's see...)
 
Top