11 and 10.3 won't boot on my laptop, but 10.1 will

drumhellar

New Member


Messages: 1

I've been trying to put FreeBSD on my laptop (Dell XPS15, l502x). Previously, the memory stick worked (10.1 works), but on FreeBSD 10.3 and 11.0 (I haven't tried 10.2), boot fails with an "Operating system not found" message on screen. My laptop uses the traditional BIOS and UEFI

I have a feeling this is due to the merging of the classic BIOS and UEFI boot images, and not quite working on computer. I don't have a DVD drive, so, how would I go about rolling my own 11.0 install image that boots the same way as 10.1?

Or, how can I fix 11.0 after writing the image to a USB stick so that it works?

I'm using Image Writer 0.9.5 to write the image from within Windows, but I do have a FreeBSD VM handy (and Linux machines available, too).
 

chrbr

Aspiring Daemon

Reaction score: 240
Messages: 669

I have recently used mfsbsd-10.3-RELEASE-amd64.img to check some disks offline and it did work. The version based on 11.0 did not boot on my system. I copied the image using dd(1). If I remember correctly the command has been dd if=./mfsbsd-10.3-RELEASE-amd64.img of=/dev/da0 bs=1M with /dev/da0 as my USB stick. But if you could prepare the USB stick for FreeBSD 10.1 using Image Writer 0.95 with success you might not need to use dd(1). Since mfsbsd-10.3-RELEASE-amd64.img is based on FreeeBSD it might be an alternative starting point. Thread 14162 is some days old but might be useful. I wish you success :beer::).
 
Top