10.3->11.0 (pf added existed routes at boot)

IPTRACE

Well-Known Member

Reaction score: 24
Messages: 321

Hello!

I've encountered the problem after upgrade to 11.0-RELEASE.
I suppose pf adding two routes which exist.
Code:
Starting Network: lo0 vtnet0.
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
        inet 127.0.0.1 netmask 0xff000000
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
        groups: lo
vtnet0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=80028<VLAN_MTU,JUMBO_MTU,LINKSTATE>
        ether 00:b1:89:3f:62:aa
        inet 10.10.11.113 netmask 0xfffffe00 broadcast 10.10.11.255
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet 10Gbase-T <full-duplex>
        status: active
Starting devd.
Starting pflog.
pflog0: promiscuous mode enabled
Oct 22 11:28:42 pflogd[322]: [priv]: msg PRIV_OPEN_LOG received
Enabling pf.
[B]add host 127.0.0.1: gateway lo0 fib 0: route already in table[/B]
add net default: gateway 10.10.11.22
[B]add host ::1: gateway lo0 fib 0: route already in table[/B]
add net fe80::: gateway ::1
add net ff02::: gateway ::1
add net ::ffff:0.0.0.0: gateway ::1
add net ::0.0.0.0: gateway ::1
Thanks for help.
Arek
 
Last edited by a moderator:

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,021
Messages: 38,472

PF doesn't add routes. At all.
 
Top