10.3 -> 11.0-current, can not install ports

I updated my system from 10.3 to 11.0 to make my centrino N-2200 wifi card work.
After updating, I download the new ports tree but could not build the ports under sysutiles/lsof
The error message is really long. I copied the top and bottom lines below.
In file included from dnode.c:39:
In file included from ./lsof.h:58:
/usr/include/stdio.h:63:9: error: unknown type name '__off64_t'; did you mean '__off_t'?
typedef __off64_t off64_t;
/usr/src/sys/sys/_types.h:53:19: note: '__off_t' declared here
typedef __int64_t __off_t; /* file offset */
make[1]: stopped in /usr/ports/11.0-current/sysutils/lsof/work/lsof_4.90B.freebsd
3 errors

make[1]: stopped in /usr/ports/11.0-current/sysutils/lsof/work/lsof_4.90B.freebsd
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

I guess the issue is cc compiler. I tried to feed the parameter CC=gccXY CXX=g++XY (XY is the version, 48,49,5 and 6), but none of them worked. "MAKE_JOBS_UNSAFE=yes" did not resolve the issue either.

Wondering I could seek some suggestions on debugging. Thanks.
Last edited by a moderator:
Thanks SirDice. I could not use pkg after going from 10.3 to 11.0. The complaint is about updating. However, when I tried that, it tells me no repository could be found. This triggered me to rebuild the ports. I could not resolve the problem until I reinstalled the 11.0 from scratch. Now it works like charm.