10.2 VBox shared folders mounting

GreggSparrow

New Member


Messages: 1

Hello,
I've installed FreeBSD 10.2 as guest in the VirtualBox on Win7 host machine, and wanted to mount shared folder with the mount command. But no luck with that.

Here's what I have:
VirtualBox 5.0.14 r105127

Code:
:[gregg:~]$ VBoxControl sharedfolder list
Oracle VM VirtualBox Guest Additions Command Line Management Interface Version 4.3.36_OSE
(C) 2008-2016 Oracle Corporation
All rights reserved.

Shared Folder mappings (1):

01 - shared
:[gregg:~]$ sudo mount -t vboxsf shared ~/share
mount: shared: Operation not supported by device
:[gregg:~]$ uname -a
FreeBSD weblab 10.2-STABLE FreeBSD 10.2-STABLE #3 r292010: Thu Dec 10 13:44:54 MSK 2015  root@weblab:/usr/obj/usr/src/sys/CUSTOM  amd64
:[gregg:~]$ pkg info | grep -i virtual
virtualbox-ose-additions-4.3.36 VirtualBox additions for FreeBSD guests
I suppose, there is still no support for mounting shared folders this way yet?
 
Last edited by a moderator:

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,677
Messages: 30,586

The Virtualbox guest additions for FreeBSD do not support shared folders.
 

Crivens

Moderator
Staff member
Moderator

Reaction score: 908
Messages: 1,884

I think they did, once. But I had to install a FreeBSD virtual box on my FreeBSD workstation, and the guest additions only cater for Solaris and Linux these days. I could work around that using sysutils/sshfs, but it is not what I seem to remember from virtualbox.
 

henninb

New Member


Messages: 8

I assume this issue with vboxsf device is planed to be fixed in added in the future? Please let me know how I could find out more info.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,677
Messages: 30,586

It's not directly a FreeBSD issue, it needs to be resolved in the guest additions. So your question is better directed at the VirtualBox developers. Having said that, I do remember a quarterly status report that mentioned some people were working on getting this supported. But I have no idea what the current status is.
 

dinsdale

Member

Reaction score: 6
Messages: 47

Hi, this worked like gangbusters for me:

https://www.freebsd.org/cgi/man.cgi?mount_smbfs

I just mounted my Windows users' share and had full access to everything in my FBSD 11.1 guest after I entered my (Windows User) password. Not sure if you can set up fstab to work with that though?

Notes:
  • I have Windows Network sharing enabled. To see what was being shared from Windows 10 I went to the networks item in a file explorer tree and clicked on my computer name.
  • I used the -I option and specified my Virtual Box host only adapter ip address (192.168.56.1 in my case) because NetBIOS wouldn't resolve.
 

artyushe

New Member

Reaction score: 1
Messages: 5

same issue with
uname -a
Code:
13.0-CURRENT r340361 GENERIC i386
pkg info | grep -i virual
Code:
virtualbox-ose-additions-5.2.22
 

artyushe

New Member

Reaction score: 1
Messages: 5

the reason of the issue : is misspelled type

:[gregg:~]$ sudo mount -t vboxsf shared ~/share



should be vboxvfs
 

AlexanderProphet

Active Member

Reaction score: 34
Messages: 156

artyushe thanks so much! That worked for me - I had the same problem as the OP.
This info really should be elsewhere though, not just on a forum post.
I have FreeBSD as a VirtualBox guest on my MacBook, and the VirtualBox app itself says to use "vboxsf" as the OP posted it! (when you hover your mouse over the list of shared folders in VirtualBox, a little tip comes up saying to type "vboxsf").
 

ShelLuser

Son of Beastie

Reaction score: 1,726
Messages: 3,546

should be vboxvfs
You do realize that the thread (aka problem) you responded to is 2 years old, right?

Are you sure it was vboxvfs back then as well? Because I have some serious doubts. And then there's SirDice's comment as well: it wasn't supported back then either.
 

AlexanderProphet

Active Member

Reaction score: 34
Messages: 156

Hmm looks like i might have spoken a bit too soon. Everything in my shared folder appears (from the FreeBSD guest’s point of view) to be owned by root and read-only. And unless I’m doing something wrong (which is entirely possible) even root cannot change the ownership or permissions.
You can of course copy files to another directory, then the copies have sensible permissions.
Has anyone else encountered this kind of problem?
 
Top