10.1->10.3/11.0 failing

Hello, I decided to take the time to upgrade my old 10.1 installation this weekend to 10.3. Execution of freebsd-update as specified here seemed to conclude without an issue up until the first restart. On restarting the system entered a cycle of rebooting with the following error displayed on-screen just before rebooting:

current process  = 0 (thread taskq)
trap number = 9
panic: general protection fault
cpuid = 0
KDB: stack backtrace:
#0 0xffffffff8098e3e0 at kdb_backtrace+0x60
#1 0xffffffff809510b6 at vpanic+0x126
#2 0xffffffff80950f83 at panic+0x43
#3 0xffffffff80d55f8b at trap_fatal+0x36b
#4 0xffffffff80d55c0d at trap+0x77d
#5 0xffffffff80d3b8d2 at calltrap+0x8
#6 0xffffffff80314eb5 at passregister+0x195
#7 0xffffffff802e39a4 at cam_periph_alloc+0x584
#8 0xffffffff80314cd0 at passasync+0xa0
#9 0xffffffff802ed21a at xptsetasyncfunc+0x11a
#10 0xffffffff802ed896 at xptdevicetraverse+0xe6
#11 0xffffffff802ed6ba at xpttargettraverse+0x9a
#12 0xffffffff802ed509 at xptbustraverse+0xa9
#13 0xffffffff802ed09d at xpt_register_async+0x25d
#14 0xffffffff80314c09 at passinit+0x19
#15 0xffffffff802e33fe at periphdriver_init+0x4e
#16 0xffffffff802ecdc6 at xpt_finishconfig_task+0x16
#17 0xffffffff8099f215 at taskqueue_run_locked+0xe5
Uptime: 5s

There's more above this block, but it scrolls by too quickly to capture.
Thinking it was a setting in /boot/loader.conf that didn't like the upgrade I booted from kernel.old and commented out everything, but still no luck.

A quick Google search found a similar, but not identical, issue from about a year ago where it turned out the ZFS pool that had transferred since 8.x had become corrupt. The boot pool is fine to destroy, so I created a USB boot image from the "FreeBSD-10.3-RELEASE-amd64-memstick.img" file and booted off the device with the intent of installing from scratch.

The USB boot image also reboots with the exact same error.

I then tried booting from "FreeBSD-11.0-RELEASE-amd64-memstick.img", and still recieved the error.

Another Google search for my mainboard and FreeBSD indicates support for my mainboard, an MSI H81I, might have been dropped in 10.2? I guess my questions are:

1. How can I determine which, if any specific, component on the mainboard is the root cause so I can disable it?

2. What's the best way to revert to 10.1 and just live in the dark ages until such time as I can afford to upgrade the hardware?

Thank you for your time.
Another Google search for my mainboard and FreeBSD indicates support for my mainboard, an MSI H81I, might have been dropped in 10.2?
I wonder where you got this from. In general support is rarely dropped for hardware. Unless it's really old hardware nobody has or uses anymore. But I very much doubt anything on your mainboard was dropped.

I'd be more inclined to check for hardware errors. Judging by the xpt* messages I'd look for disk and/or controller errors first.
An LGA1150 socket and DDR3 RAM is not even close to being old. In fact that particular board is probably not even as old as FreeBSD 10.0.
First download a version of FreeBSD 10.1 put it on a memstick and try to boot, if this success you can then downgrading to 10.1.
For that 2 possibilities(the first should work, the second I am not sure):
If you can boot in single mode, you can with another computer download the svn revision of the /usr/src that match the version 10.1 of FreeBSD in a memstick and then mount it , copy files to /usr/src and then follow instruction for rebuilding world and kernel https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/makeworld.html
If you can't , use the live version of the FreeBSD 10.1 memstick , and mount your hard drive in /mnt , and then put the /usr/src in it , and chroot in /mnt , and follow the same procedure that if you can boot in single mode
Last edited: