1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

xrdp

Discussion in 'Web and Network Services' started by DemoDoG, Nov 18, 2008.

  1. DemoDoG

    DemoDoG Member

    Messages:
    193
    Thanks Received:
    0
    Has anyone got xrdp to work good on FreeBSD? Are there any good alternatives? This is my case:

    I have a computer at work from which I can connect to anything outside (SSH/remote desktop etc).
    But I can´t install anything on it.
    So I can remote desktop to my home windows xp computer. I would like to be able to remote desktop from it directly to my freeBSD computer at home.

    It´s seems xrdp is a remote desktop server for unix so it should work like I want :)
     
  2. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,530
    Thanks Received:
    2,352
    I use tsclient, which is a gnome/gtk front-end for rdesktop. Works pretty good. But it's the wrong way around for you ;)

    For taking over my freebsd desktop from work I use either vino (remote desktop feature of gnome) or tightvnc. Both use the vnc protocol, so you can use a vncviewer on windows. Tightvnc has windows executables, you don't need to install them, just the vncviewer exe will do fine.
     
  3. none

    none New Member

    Messages:
    99
    Thanks Received:
    2
    for windows rdp client, I use rdesktop and no complaint.

    for remote freebsd desktop, go as said bellow :)

    I kind had problem with vino. My ubuntu desktop just talked with vnc client from fedora and from ubuntu itself. here they use ultravnc and it doesn't like the ubuntu server. the oposite way also doesn't work. (I can easily solve the problem of unix server, win client, but the opposite I don't know)

    does anyone knows a ultravnc client for use in FreeBSD ?

    thanks,

    none
     
  4. DemoDoG

    DemoDoG Member

    Messages:
    193
    Thanks Received:
    0
    the only problem is that I cant even run vncviewer.exe on the computer because i have no right for that :) but i can remote desktop from it to my home windows xp. well I will try this xrdp thing, it´s even in the ports...
     
  5. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,530
    Thanks Received:
    2,352
    I have my own little problems with vino. Don't get me wrong it's great for what it's supposed to do but vino makes my whole desktop available, that's 2 1600x1200 displays.. It gets a bit tricky trying to view it on my pda, which only has 480x640 :e

    Let us know how xrdp is working out. I'm tempted to try it myself :)
     
  6. DemoDoG

    DemoDoG Member

    Messages:
    193
    Thanks Received:
    0
    Unfortunately it didn´t work very well. I installed xrdp from ports and there is no error when i start it. But when I try to connect from my windows computer with remote desktop it stops and I get the error "Bad protocol error"
     
  7. DemoDoG

    DemoDoG Member

    Messages:
    193
    Thanks Received:
    0
    I cant get it to work. According to this site http://blogs.23.nu/c0re/2007/05/antville-15110/ there is an error in this port that makes it not able to run. I have tried patching it like it says, downloaded the sourcefile and tried to patch it but didnt work. Is there any other way of connecting to a freebsd box using the RDP protocol.
     
  8. trasz@

    trasz@ Member Developer

    Messages:
    200
    Thanks Received:
    46
    @DemoDoG: Could you submit a PR describing the problem, possibly including that link? Web interface for submitting bugs is at http://www.freebsd.org/send-pr.html. Be sure to set the "Category" field to "ports" and include the port name in the "one line summary" field.
     
  9. catphish

    catphish New Member

    Messages:
    8
    Thanks Received:
    3
    Hello,

    I have used xrdp pretty successfully on Linux so your post intrigued me. I just set up a working xrdp server on FreeBSD 7.0 after reading this thread.

    Where are you getting that "Bad protocol error" error message? In the sessman.log? 3350 is private port for sessman. xrdp is happily listening on the default rdp port at localhost:3389.

    You said you have access to ssh on your windows workstation. Does this ssh client also support tunnels? The reason I ask is because the fastest way to get up and running is to ssh/tunnel into your target host. You want to use <some_port>:localhost:3389 for the tunnel. You may not be able to use 3389 for <some_port> on the windows workstation as windows sometimes has this port already configured for local use. Next, open windows rdp client and put in localhost:<some_port> and click connect to enjoy rdp quickness.

    You will probably want to tweak the startwm.sh.

    Good Luck!
     
  10. DemoDoG

    DemoDoG Member

    Messages:
    193
    Thanks Received:
    0
    It worked better now after the port of xrdp had been upgraded. Although it is not working for me. I get to the login field and enter usernamn/password. But when I login it says:
    Error sesman refused connection!
    any ideas?
     
  11. zuit

    zuit New Member

    Messages:
    1
    Thanks Received:
    0
    Can we get some help with the Xrdp port?

    I can't find any good documentation on the port.

    -Brian
     
  12. dzodzo

    dzodzo New Member

    Messages:
    15
    Thanks Received:
    0
    i'd second that, after some searching i couldn't find a comprehensive howto for setting up xrdp on freebsd and the man page is really laconic
     
  13. dzodzo

    dzodzo New Member

    Messages:
    15
    Thanks Received:
    0
    got the xrdp working but only with Xvnc server as the X11-rdp binary is missing and not even in the sources. I posted a question regarding this to the mailing list freebsd-x11, if anything changes i'll let you know.