1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Xorg - how to change font size

Discussion in 'X.Org' started by hennesse, Aug 19, 2011.

  1. hennesse

    hennesse New Member

    Messages:
    13
    Thanks Received:
    0
    Hi,

    I installed Xorg on my 8.1 system. "startx" gives me a login and 2 xterm windows. The text is so small that I need to use reading glasses. How can I make it bigger?

    It's a special-purpose machine, so I only need to do two things - run Firefox and vi. Firefox works fine. So I don't need any window managers or other complex stuff (I'm a command-line guy). I just wanna be able to read the screen.

    Thanks,
    Dave


    The "special purpose" is controlling a home beer brewery (FreeBSD can do anything!)
    http://www.davehennessey.com/brewery/photos/
     
  2. wblock@

    wblock@ Administrator Staff Member Administrator Moderator Developer

    Messages:
    11,512
    Thanks Received:
    2,213
    Edit .xinitrc to start the xterms with a different font size. See xterm(1).
     
    hennesse thanks for this.
  3. hennesse

    hennesse New Member

    Messages:
    13
    Thanks Received:
    0
    Solved!

    Well, not solved yet, but you got me going in the right direction.

    Already learned how to start up with the xterms in nice locations on the screen, autostart firefox, and twm as a "minimalist" window manager. I'll do my homework and figure out the darn font thing.

    Thanks!
    Dave
     
  4. wblock@

    wblock@ Administrator Staff Member Administrator Moderator Developer

    Messages:
    11,512
    Thanks Received:
    2,213
    Try -fn 10x20 as an option.
     
  5. femc7488

    femc7488 New Member

    Messages:
    16
    Thanks Received:
    1
    Add .Xdefaults to user's home directory and append the code below

    Code:
    XTerm*utf8Title: true
    XTerm*multiClickTime: 500
    XTerm*faceName: Bitstream Vera Sans Mono
    XTerm*faceSize: 10 # font size
    XTerm*title: X-Terminal
    XTerm*internalBorder: 10
    XTerm*geometry: 80x20 # xterm geometry size
    XTerm*saveLines: 1000
    XTerm*visualBell: true
    XTerm*colorULMode: true
    XTerm*colorUL: #cc0000
    XTerm*pointerMode: 0
     
    hennesse thanks for this.
  6. hennesse

    hennesse New Member

    Messages:
    13
    Thanks Received:
    0
    SOLVED - Many thanks

    A combination of .xinitrc and .Xdefaults did exactly what I wanted it to.

    .xinitrc opens the windows the way I want them to look initially.

    .Xdefaults not only allows finer control of the window appearance, but it makes any new xterms opened by twm look good too - in case I close the initial one, or need another.

    This combo opens Firefox, a "programmer's window", and the twm window manager.

    .xinitrc
    Code:
    xsetroot -solid gray &
    xterm -geometry 80x24+10+10 -fn 10x20 -n "Use of this window may void your warranty" &
    exec firefox3 &
    exec twm
    

    .Xdefaults
    Code:
    XTerm*utf8Title: true
    XTerm*multiClickTime: 500
    XTerm*faceName: Bitstream Vera Sans Mono
    XTerm*faceSize: 14 # font size
    XTerm*internalBorder: 10
    XTerm*saveLines: 1000
    XTerm*visualBell: false
    XTerm*colorULMode: true
    XTerm*colorUL: #cc0000
    XTerm*pointerMode: 0
    
    # XTerm*title: X-Terminal  # it overrides .xinitrc's settings
    # XTerm*geometry: 80x20    # caused error messages (conflict with .xinitrc?)
    # XTerm*visualBell: true   # changed to false - see below
    

    I'm an old dog - back in the late 1980s/early 1990s, I developed the bad habit of hitting the ESC key multiple times when changing modes in vi - to get that re-assuring bell. If I was particular satisfied with the line I just typed, I'd hit ESC twice. If I was angry, or didn't know what to do next, I might hit ESC three or four times. Multiple "visual bells" just aren't the same. You can teach an old dog new tricks, but it's hard to erase bad habits.

    Thanks again,
    Dave
     
  7. michaelrmgreen

    michaelrmgreen Member

    Messages:
    210
    Thanks Received:
    15